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Πρόλογος 

Τις τελευταίες δεκαετίες παρατηρείται μία ραγδαία ανάπτυξη στο τομέα της τεχνολογίας. Τα 

σύγχρονα τεχνολογικά επιτεύγματα έχουν εισχωρήσει και έχουν επηρεάσει σε μεγάλο βαθμό 

κάθε πτυχή της ανθρώπινης δραστηριότητας και δημιουργίας. Ως εκ τούτου, ο τομέας της 

εκπαίδευσης δεν θα μπορούσε να παραμείνει ανεπηρέαστος από τις νέες τεχνολογικές 

εξελίξεις. 

Καθίσταται πλέον σαφής η ανάγκη προσαρμογής της εκπαιδευτικής διαδικασίας στις 

απαιτήσεις της σύγχρονης εποχής μέσω της ενσωμάτωσης της ψηφιακής τεχνολογίας στις 

διδακτικές μεθόδους και δραστηριότητες. Η χρήση υπολογιστικών συστημάτων για την 

πρακτική εξάσκηση των μαθητών, η πλειοψηφία των οποίων είναι αρκετά εξοικειωμένοι με τις 

νέες τεχνολογίες, θα καθιστούσε πιο ενδιαφέρουσα και ελκυστική την εκπαίδευση και για τον 

λόγο αυτό, τα τελευταία χρόνια παρατηρείται μία αυξανόμενη τάση στη χρήση διάφορων 

εφαρμογών στη μαθησιακή διαδικασία.  

Μία τεχνολογία που αναπτύσσεται ταχύτατα την τελευταία πενταετία, αν και η εφαρμογή της 

βρίσκεται ακόμα σε αρχικό στάδιο, είναι αυτή της εκτεταμένης πραγματικότητας (Extended 

Reality). Ο συγκεκριμένος όρος περιλαμβάνει και συνδυάζει τις έννοιες της εικονικής 

πραγματικότητας (Virtual Reality), της μικτής πραγματικότητας (Mixed Reality) και της 

επαυξημένης πραγματικότητα (Augmented Reality). Η χρήση των παραπάνω τεχνολογιών 

στην εκπαιδευτική διαδικασία προσφέρει πολλαπλά οφέλη τόσο για τους μαθητές όσο και για 

τους εκπαιδευτικούς. Η συγκεκριμένη διπλωματική εργασία εστιάζει στη χρήση της 

επαυξημένης πραγματικότητας στο μάθημα Φυσικά Δημοτικού – Ερευνώ και Ανακαλύπτω της 

ΣΤ’ τάξης.  



iv 

Περίληψη 

Η παρούσα πτυχιακή εργασία επικεντρώνεται στη δημιουργία ενός παιχνιδιού επαυξημένης 

πραγματικότητας για το μάθημα Φυσικά Δημοτικού – Ερευνώ και Ανακαλύπτω της ΣΤ’ τάξης. 

Ο κύριος στόχος του παιχνιδιού είναι να διευκολύνει την υλοποίηση των πειραμάτων του 

μαθήματος και να συνεισφέρει στην καλύτερη κατανόηση των σύνθετων εννοιών και 

φαινομένων από τους μαθητές, κάνοντας παράλληλα πιο προσιτή και ευχάριστη τη διδακτική 

διαδικασία. Για κάθε ένα από τα κεφάλαια του βιβλίου, εντός της διδακτέας ύλης για την 

σχολική χρονιά 2020-2021, ο χρήστης θα μπορεί να σκανάρει ένα qrcode, μέσω κινητού 

τηλεφώνου ή ταμπλέτας, το οποίο θα βρίσκεται στην αντίστοιχη σελίδα του σχολικού βιβλίου 

και στην συνέχεια θα εμφανίζεται μπροστά του ένας λαβύρινθος με χρήση επαυξημένης 

πραγματικότητας. Από τα διάφορα αντικείμενα που θα βρίσκονται εντός του λαβυρίνθου ο 

χρήστης θα πρέπει να ακολουθήσει την μοναδική σωστή διαδρομή από την οποία θα συλλέγει 

τα απαραίτητα αντικείμενα για την υλοποίηση του πειράματος. Αφού ολοκληρωθεί η συλλογή 

των αντικειμένων θα εφαρμόζεται το πείραμα με χρήση επαυξημένης πραγματικότητας. 

 

Λέξεις κλειδιά: Φυσικά Δημοτικού – Ερευνώ και Ανακαλύπτω, Εκτεταμένη Πραγματικότητα, 

Εικονική Πραγματικότητα, Επαυξημένη Πραγματικότητα, Μικτή Πραγματικότητα, Unity, AR 

Foundation, XR Interaction Subsystems, ProBuilder, TextMeshPro, Vuforia Engine AR. 
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The use of augmented reality in education: The creation of a Game for 

the subject of Physics of the 6th grade of primary school 

 

Feneridis Anastasios 

 

Abstract 

This dissertation focuses on creating an augmented reality game for the subject of Physics of 

the 6th grade. The main goal of the game is to facilitate the implementation of the experiments 

and to contribute to the better understanding of complex concepts and phenomena by students, 

while making the teaching process more accessible and enjoyable. For each one of the chapters 

of the book, within the curriculum of the school year 2020-2021, the user will be able to scan a 

qrcode, via mobile phone or tablet, which will be on the related page of the textbook. Then a 

maze appears in front of them using augmented reality. From the various objects that will be 

inside the maze, the user will have to follow the sole correct path from which they will collect 

the necessary objects for the implementation of the experiment. Once the collection of objects 

is complete the experiment will be applied using augmented reality. 

 

Keywords: Physics -6th grade of primary school, Extended Reality, Virtual Reality, 

Augmented Reality, Mixed Reality, Unity, AR Foundation, XR Interaction Subsystems, 

ProBuilder, TextMeshPro, Vuforia Engine AR. 
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Κεφάλαιο 1ο: Εισαγωγή 

Ο τίτλος της παρούσας διπλωματικής εργασίας είναι «Η χρήση της επαυξημένης 

πραγματικότητας στην εκπαίδευση: Ανάπτυξη παιχνιδιού για το μάθημα Φυσικά – Ερευνώ και 

Ανακαλύπτω της ΣΤ’ Δημοτικού». Ο κύριος στόχος του παιχνιδιού είναι να διευκολύνει την 

υλοποίηση των πειραμάτων του μαθήματος και να συνεισφέρει στην καλύτερη κατανόηση των 

σύνθετων εννοιών και φαινομένων από τους μαθητές, κάνοντας παράλληλα πιο προσιτή και 

ευχάριστη τη διδακτική διαδικασία. Στο πλαίσιο αυτό η παρούσα διπλωματική εργασία 

επιχειρεί να πραγματοποιήσει μία ανάλυση των σύγχρονων εκπαιδευτικών προσεγγίσεων και 

να προτείνει τρόπους εφαρμογής τους μέσα από τη χρήση των συγχρόνων τεχνολογιών στην 

εκπαιδευτική διαδικασία. Πιο συγκεκριμένα, οι τεχνολογίες στις οποίες εστιάζει η 

Διπλωματική Εργασία είναι αυτές της Εκτεταμένης Πραγματικότητας, δηλαδή της Εικονικής 

Πραγματικότητας, της Μικτής Πραγματικότητας και της Επαυξημένης Πραγματικότητας.  

Η εφαρμογή PhysicX-R βασίζεται στη χρήση της Επαυξημένης Πραγματικότητας και δίνει την 

ευκαιρία στους εκπαιδευτικούς να εντάξουν στη διδασκαλία του μαθήματος Φυσικά – Ερευνώ 

και Ανακαλύπτω της ΣΤ’ Δημοτικού μία καινοτόμο μέθοδο που θα προκαλέσει και θα 

διατηρήσει το ενδιαφέρον των μαθητών, θα τους παρακινήσει να συμμετέχουν ενεργά στο 

μάθημα και να συνεργάζονται και θα τους βοηθήσει να κατανοήσουν τις πολύπλοκες έννοιες 

του μαθήματος καλλιεργώντας παράλληλα και πολλές άλλες δεξιότητες των μαθητών. 

Επιπρόσθετα, στόχος της παρούσας διπλωματικής είναι να συμβάλλει στη γνώση σχετικά με 

την επίδραση των τεχνολογιών Εκτεταμένης Πραγματικότητας στη διδακτική και μαθησιακή 

διαδικασία κυρίως στον χώρο των Φυσικών Επιστημών. 

Η Διπλωματική Εργασία αποτελείται από εννέα συνολικά κεφάλαια, τα οποία με τη σειρά τους 

χωρίζονται σε επιμέρους ενότητες. 

 Το πρώτο κεφάλαιο φέρει τον τίτλο «Εισαγωγή» και παρουσιάζει τους κύριους στόχους και 

την σημαντικότητα της παρούσας διπλωματικής εργασίας, και πιο συγκεκριμένα της 

εφαρμογής του παιχνιδιού PhysicX-R. Επιπλέον, στο κεφάλαιο αυτό πραγματοποιείται μία 

σύντομη παρουσίαση των περιεχομένων όλων των κεφαλαίων.  

Στο δεύτερο κεφάλαιο «Χρήση σύγχρονων τεχνολογιών στην εκπαίδευση» πραγματοποιείται 

αρχικά η παρουσίαση των βασικών εννοιών της εικονικής, της μικτής και της επαυξημένης 

πραγματικότητας, οι οποίες περικλείονται στον όρο της εκτεταμένης πραγματικότητας. Στη 

συνέχεια γίνεται αναφορά στις σύγχρονες εκπαιδευτικές προσεγγίσεις και στον τρόπο με τον 

οποίο οι παραπάνω τεχνολογίες θα μπορούσαν να συμβάλλουν δυναμικά στις διάφορες αυτές 

κατευθύνσεις. Τέλος, αφού πραγματοποιηθεί μία σύντομη παρουσίαση των πλεονεκτημάτων 

που προκύπτουν από την χρήση των τεχνολογιών εκτεταμένης πραγματικότητας στην 

εκπαιδευτική διαδικασία, παρουσιάζεται η εφαρμογή PhysicX-R. 

Το τρίτο κεφάλαιο «Εγκατάσταση Unity και ρυθμίσεις πλατφόρμας» περιλαμβάνει την 

περιγραφή της πλατφόρμας που επιλέχθηκε για την υλοποίηση της εφαρμογής και όλα τα 

βήματα που ακολουθήθηκαν για την εγκατάσταση και τις ρυθμίσεις των βασικών παραμέτρων 
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αυτής. Επιπλέον, γίνεται μία εκτενής παρουσίαση όλων των πακέτων που χρησιμοποιήθηκαν 

κατά το σχεδιασμό και τη δημιουργία του παιχνιδιού.  

Στο τέταρτο κεφάλαιο «Βασικό μενού παιχνιδιού» γίνεται αρχικά μία μικρή αναφορά στην 

διδακτέα ύλη 2020-2021 του μαθήματος Φυσικά – Ερευνώ και Ανακαλύπτω της ΣΤ’ 

Δημοτικού και στα πειράματα που επιλέχθηκαν προς υλοποίηση με την εφαρμογή PhysicX-R. 

Στην συνέχεια, γίνεται η αναλυτική περιγραφή της δημιουργίας της Αρχικής σκηνής του 

παιχνιδιού, δηλαδή του κεντρικού μενού, καθώς και των ρυθμίσεων του ήχου και του 

κεντρικού χαρακτήρα του παιχνιδιού. 

Τα εναπομείναντα τέσσερα κεφάλαια της παρούσας διπλωματικής εργασίας αναφέρονται 

εκτενώς σε όλα τα βήματα που ακολουθήθηκαν για τη δημιουργία των παιχνιδιών και της 

εφαρμογής του πειράματος για το κάθε ένα από τα κεφάλαια εντός της διδακτέας ύλης του 

βιβλίου Φυσικά – Ερευνώ και Ανακαλύπτω της ΣΤ’ Δημοτικού. Πιο συγκεκριμένα, το 

κεφάλαιο πέντε ονομάζεται «Εφαρμογή πειράματος για το κεφάλαιο Θερμότητα», το κεφάλαιο 

έξι ονομάζεται «Εφαρμογή πειράματος για το κεφάλαιο Ηλεκτρομαγνητισμός», το κεφάλαιο 

επτά ονομάζεται «Εφαρμογή πειράματος για το κεφάλαιο Φως» και το κεφάλαιο οκτώ 

ονομάζεται «Εφαρμογή πειράματος για το κεφάλαιο Οξέα- Βάσεις- Άλατα». Η δομή των 

παραπάνω κεφαλαίων είναι ίδια, καθώς για το κάθε ένα από αυτά έχει σχεδιαστεί ένα παρόμοιο 

παιχνίδι εκτεταμένης πραγματικότητας με σκοπό την εκτέλεση του εκάστοτε πειράματος. 

Τέλος, η διπλωματική εργασία ολοκληρώνεται με το κεφάλαιο εννιά «Συμπεράσματα και 

προτάσεις» στο οποίο παρουσιάζονται τα συμπεράσματα που προέκυψαν από την εκπόνηση 

της εργασίας καθώς και κάποιες προτάσεις για τη μελλοντική βελτίωση και εξέλιξη της 

εφαρογής. 
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Κεφάλαιο 2ο: Χρήση σύγχρονων τεχνολογιών στην εκπαίδευση 

2.1 Εισαγωγή 

Το παρόν κεφάλαιο αναφέρεται αρχικά στις αναδυόμενες τεχνολογίες της Εκτεταμένης 

Πραγματικότητας (Extended Reality - XR). Ο συγκεκριμένος όρος εμπεριέχει τις τεχνολογίες 

της Εικονικής Πραγματικότητας (Virtual Reality - VR), της Επαυξημένης Πραγματικότητας 

(Augmented Reality - AR) και της Μικτή Πραγματικότητας (Mixed Reality - MR), οι οποίες 

και αναλύονται στη συνέχεια. Επιπλέον, γίνεται εκτενής αναφορά στις σύγχρονες 

εκπαιδευτικές προσεγγίσεις της Εγκαθιδρυμένης μάθησης, του Εποικοδομισμού, του 

Κοινωνικού Εποικοδομισμού και του Συμπεριφορισμού και στον τρόπο με τον οποίο οι 

τεχνολογίες εκτεταμένης πραγματικότητας θα μπορούσαν να συμβάλουν στις συγκεκριμένες 

εκπαιδευτικές κατευθύνσεις. Τέλος, το κεφάλαιο ολοκληρώνεται με την παρουσίαση της 

εφαρμογής PhysicX-R και τους σκοπούς δημιουργίας της. 

2.2 Εκτεταμένη Πραγματικότητα 

Ο όρος της Εκτεταμένης Πραγματικότητας (Extended Reality - XR) αποτελεί έναν καθολικό 

όρο ο οποίος περιλαμβάνει όλες τις υπάρχουσες και μελλοντικές βιωματικές τεχνολογίες που 

μέσα από τον συνδυασμό πραγματικών και εικονικών περιβαλλόντων καταφέρνουν να 

προσφέρουν συναρπαστικές εμπειρίες. Πιο συγκεκριμένα, περιλαμβάνει ένα ολόκληρο φάσμα 

τεχνολογιών που κυμαίνονται από το πλήρως πραγματικό έως το πλήρως εικονικό, όπως η 

Εικονική Πραγματικότητα (Virtual Reality - VR), η Επαυξημένη Πραγματικότητα (Augmented 

Reality - AR) και η Μικτή Πραγματικότητα (Mixed Reality - MR) [1].  

Επί του παρόντος, η πιο κοινή μορφή εκτεταμένης πραγματικότητας είναι η εικονική 

πραγματικότητα (VR), η οποία αναπτύχθηκε για πρώτη φορά τη δεκαετία του 1960 ως 

αποτέλεσμα της προσπάθειας ενός φοιτητή ηλεκτρολόγου μηχανικού να αναπτύξει ανθρώπινη 

αλληλεπίδραση με υπολογιστές. Το VR αυξήθηκε αργά και επέκτεινε το αποτύπωμά του στον 

κόσμο. Καθ 'όλη τη διάρκεια της δεκαετίας του 1970 και του 1980, ορισμένες αγορές μπόρεσαν 

να βρουν οφέλη για τη μείωση του κόστους στο VR, όπως η πτήση και προσομοιώσεις 

συντριβών για τις αεροπορικές και αυτοκινητοβιομηχανίες, και χειρουργικές εκπαιδεύσεις 

στον ιατρικό τομέα. Ωστόσο, ενώ αυτή τη στιγμή αποφέρει σημαντικά κέρδη στη βιομηχανία 

ψυχαγωγίας, στο παρελθόν θεωρούνταν πολύ δύσκολο να πουληθεί. Τα τρισδιάστατα 

βιντεοπαιχνίδια κυκλοφόρησαν το 1987, το 1995 και το 2011 πριν τελικά γίνουν κερδοφόρα 

και αυτό μπορεί να αποδοθεί σε μεγάλο βαθμό στις εξελίξεις υλικού και λογισμικού. Οι 

οικιακοί υπολογιστές πριν από 15 χρόνια δεν ήταν αρκετά ισχυροί για να υποστηρίξουν 

ρεαλιστικό VR και γραφικά [2]. 

Αλλά ακόμη και τα σημερινά έξυπνα τηλέφωνα έχουν υψηλότερη ποιότητα οθόνης, 

αισθητήρες και προσβασιμότητα από τους προκατόχους υπολογιστών μόλις μια δεκαετία 

νωρίτερα. Επίσης, οι τιμές και τα μεγέθη τόσο των υπολογιστών όσο και των κινητών 

τηλεφώνων συνέχισαν να μειώνονται, αυξάνοντας την προσωπική κινητικότητα και τις 

πωλήσεις του κλάδου. 
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Μόλις η Google παρουσίασε στο κοινό τα γυαλιά επαυξημένης πραγματικότητας, το Google 

Glass, το 2012 το XR κέρδισε μεγάλη προσοχή για τους καταναλωτές. Αυτό συνεχίστηκε όταν 

το Facebook απέκτησε το Oculus για 2 δισεκατομμύρια δολάρια ΗΠΑ το 2014 και το 

ενδιαφέρον τόσο από τις επιχειρήσεις όσο και από τους καταναλωτές συνεχίζει να αυξάνεται 

σε μεγάλο βαθμό μέρος λόγω της οπτικής γραφικής ανάπτυξης στη βιομηχανία των 

βιντεοπαιχνιδιών και της ευρύτερης κινητικότητας που προσφέρεται από έξυπνα τηλέφωνα [3].  

2.2.1 Εικονική Πραγματικότητα 

Η Εικονική Πραγματικότητα (Virtual Reality - VR) δεν διαθέτει ένα κοινώς αποδεκτό ορισμό 

καθώς υπάρχουν διάφοροι τρόποι υλοποίησης αλλά και χρήσης της συγκεκριμένης 

τεχνολογίας. Αρχικά, την δεκαετία του ΄80 ο Jaron Lanier [4] όρισε την Εικονική 

Πραγματικότητα ως «Ένα αλληλεπιδραστικό, τρισδιάστατο περιβάλλον, παραγόμενο από 

υπολογιστή στο οποίο μπορεί κάποιος να εμβυθιστεί». Σε επόμενους ορισμούς που 

ακολούθησαν η έννοια της εμβύθισης, δηλαδή της ψευδαίσθησης που έχει ο χρήστης σχετικά 

με την ύπαρξη του εντός του εικονικού περιβάλλοντος, συνέχισε να κατέχει κεντρικό ρόλο. 

Ωστόσο, οι πιο πρόσφατες ερμηνευτικές προσεγγίσεις, όπως αυτή των Manetta και Blade [5], 

δίνουν επίσης σημαντική έμφαση τόσο στη δομή όσο και στην έννοια της πλοήγησης. Ο τρόπος 

δημιουργία των εφαρμογών εικονικής πραγματικότητας σχετίζεται με τα λειτουργικά 

χαρακτηριστικά του εκάστοτε συστήματος, τα οποία διακρίνονται είτε σε παθητικά, δηλαδή 

συστήματα στα οποία ο χρήστης έχει την δυνατότητα να κινείται εντός του εικονικού κόσμου 

χωρίς όμως να ασκεί κάποιου είδους έλεγχο μέσα σε αυτό, και τα ενεργητικά συστήματα, στα 

οποία ο χρήστης διαθέτει κάποιο επίπεδο ελέγχου. Τα ενεργητικά συστήματα με τη σειρά τους 

μπορούν να διακριθούν επίσης στα εξερευνητικά περιβάλλοντα στα οποία αν και η κίνηση της 

κάμερας είναι ελεύθερη δεν υποστηρίζεται η αλληλεπίδραση με τα αντικείμενα και στα 

αλληλεπιδραστικά περιβάλλοντα τα οποία προσφέρουν τη δυνατότητα αλληλεπίδρασης είτε με 

αντικείμενα είτε και με άλλους ταυτόχρονους χρήστες του εικονικού κόσμου. Συνοψίζοντας, 

μπορούμε να πούμε ότι οι εικονικοί κόσμοι χαρακτηρίζονται από τρεις θεμελιώδης έννοιες, την 

εμβύθιση που επιτυγχάνει την απομόνωση του χρήστη από τα ερεθίσματα του εξωτερικού 

κόσμου, την πλοήγηση που αφορά την περιήγηση του χρήστη στον εικονικό κόσμο και την 

αλληλεπίδραση μεταξύ του χρήστη και των αντικείμενων του εικονικού κόσμου ή τους λοιπούς 

χρήστες αυτού. Τέλος όσον αφορά τον ειδικό εξοπλισμό, που θα αποφέρει έναν ικανοποιητικό 

βαθμό εμβύθισης για μία ολοκληρωμένη εμπειρία VR, αυτός μπορεί να είναι τα κράνη 

εικονικής πραγματικότητας, ακουστικά που προσφέρουν ηχητική απομόνωση, γάντια ή ακόμη 

και ολόσωμες φόρμες, κ.ά. [6]. 

2.2.2 Επαυξημένη Πραγματικότητα 

Σε αντίθεση με την Εικονική Πραγματικότητα που, όπως είδαμε παραπάνω, βασίζεται στην 

πλήρη εμβύθιση του χρήστη σε ένα φανταστικό και ψηφιακό κόσμο, η Επαυξημένη 

Πραγματικότητα (Augmented Reality - AR) ενσωματώνει την ψηφιακή πληροφορία στον 

πραγματικό κόσμο του χρήστη. Πρόκειται δηλαδή για μία τεχνολογία η οποία με την χρήση 

διάφορων τεχνολογιών χωροθέτησης όπως οι ενσωματωμένες σε συσκευές κάμερες, 

αισθητήρες βάθους και κίνησης ή διεύθυνσης, το GPS (Global Positioning System), κ.ά., 
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επιτρέπει τόσο την χωρική όσο και την χρονική συσχέτιση της ψηφιακής και τρισδιάστατης 

πληροφορίας με τον φυσικό κόσμο, όπως τον αντιλαμβάνεται ο χρήστης μέσα από τις 

αισθήσεις του, και σε πραγματικό χρόνο. Επιπλέον, αξίζει να αναφερθεί πως αν και μέχρι 

σήμερα η επαυξημένη πραγματικότητα χρησιμοποιείται κυρίως ως ένα οπτικό μέσο, αποτελεί 

επίσης μία τεχνολογία η οποία έχει τη δυνατότητα να ερεθίσει πολλές από τις αισθήσεις μας. 

Σε μία εμπειρία επαυξημένης πραγματικότητας η αλληλεπίδραση του χρήστη με το φυσικό 

περιβάλλον διεξάγεται κανονικά και με τον ίδιο τρόπο ως συνήθως με τη διαφορά ότι πάνω σε 

αυτό τον πραγματικό κόσμο υπάρχουν ψηφιακές προσθήκες που επαυξάνουν πράγματα και 

αντικείμενα τα οποία κανονικά ο χρήστης δεν θα ήταν σε θέση να δει, να αγγίξει ή να ακούσει 

[6]. Για την καλύτερη κατανόηση όλων των παραπάνω θα μπορούσαμε να φανταστούμε μία 

επίσκεψη σε έναν αρχαιολογικό χώρο όπου ο επισκέπτης βρισκόμενος μπροστά από τα ερείπια 

θα είχε τη δυνατότητα μέσα από τη χρήση μίας φορητής συσκευής και με την χρήση 

τεχνολογίας επαυξημένης πραγματικότητας να δει αλλά και να αλληλοεπιδράσει με τα κτήρια, 

τα έπιπλα ή ακόμα και τα αντικείμενα εκείνης της εποχής που θα ζωντανεύουν μπροστά του 

στην ακριβή θέση των ερειπίων, όπως φαίνεται στην εικόνα 2.1. 

 

Εικόνα 2.2: Παράδειγμα Επαυξημένης Πραγματικότητας 

 

Συνοψίζοντας, τα βασικά χαρακτηριστικά της τεχνολογίας επαυξημένης πραγματικότητας, 

σύμφωνα με τον Ronald Azuma [7], είναι ο συνδυασμός πραγματικού και εικονικού κόσμου, 

η διαδραστικότητα και η αλληλεπίδραση σε πραγματικό χρόνο και η τρισδιάστατη 

χωρομέτρηση της πληροφορίας.  

2.2.3 Μικτή Πραγματικότητα 

Η Μικτή Πραγματικότητα (Mixed Reality - MR) είναι ένα βήμα πέρα από την Επαυξημένη 

Πραγματικότητα και πρόκειται ουσιαστικά για την συγχώνευση του πραγματικού και του 

εικονικού κόσμου με σκοπό την παραγωγή νέων περιβαλλόντων όπου τα αντικείμενα και των 

δύο αυτών κόσμων μπορούν να συνυπάρχουν αλλά και να αλληλοεπιδρούν μεταξύ τους. Ενώ 

η Επαυξημένη Πραγματικότητα, όπως είδαμε στην προηγούμενη ενότητα, λαμβάνει χώρα στον 

πραγματικό κόσμο επαυξάνοντας και προσθέτοντας αντικείμενα με σκοπό να ενισχύσει την 

αντίληψη του χρήστη για τον πραγματικό κόσμο, η Μικτή Πραγματικότητα δεν λαμβάνει χώρα 

αποκλειστικά ούτε στον φυσικό κόσμο ούτε στον εικονικό κόσμο, αλλά αποτελεί ένα υβρίδιο 
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πραγματικότητας και εικονικής πραγματικότητας που μπορεί να θολώσει τη διαφορά μεταξύ 

του πραγματικού και του μη. Στη μικτή πραγματικότητα, ο χρήστης έχει τη δυνατότητα να 

αλληλοεπιδρά και να χειρίζεται τόσο τα φυσικά όσο και τα εικονικά αντικείμενα και 

περιβάλλοντα, χρησιμοποιώντας τεχνολογίες ανίχνευσης και απεικόνισης. Για παράδειγμα, 

παίζοντας ένα παιχνίδι μπάσκετ σε ένα περιβάλλον μικτής πραγματικότητας, ο χρήστης θα 

μπορούσε να επιλέξει μια μπάλα που βρίσκεται στο δωμάτιό του και να την φέρει μέσα στο 

παιχνίδι. Με άλλα λόγια, η Μικτή Πραγματικότητα παρέχει τη δυνατότητα στον χρήστη να 

έχει το ένα πόδι (ή το χέρι) στον πραγματικό κόσμο και το άλλο σε ένα εικονικό μέρος, 

διασπώντας βασικές έννοιες μεταξύ πραγματικού και φανταστικού, προσφέροντας έτσι μια 

εμπειρία που μπορεί να αλλάξει τον τρόπο που παίζουμε, μαθαίνουμε και εργαζόμαστε σήμερα. 

Στην εικόνα 2.2 συγκεντρώνονται περιληπτικά οι βασικές διαφορές των τριών αυτών 

τεχνολογιών που αναλύσαμε παραπάνω. 

 

Εικόνα 2.3: VR vs AR vs MR 

 

2.3 Σύγχρονες εκπαιδευτικές προσεγγίσεις και Εκτεταμένη Πραγματικότητα 

Εδώ και αρκετές δεκαετίες παρατηρείται μία αυξανόμενη χρήση των υπολογιστών και των 

νέων τεχνολογιών στην εκπαιδευτική διαδικασία. Έτσι, όπως ήταν αναμενόμενο, οι 

τεχνολογίες XR, VR, AR και MR, μετά την τεράστια εξάπλωση τους στο χώρο της ψυχαγωγίας, 

κατέκτησαν και τον τομέα της εκπαίδευσης. Αρχικά η αξιοποίηση των τεχνολογιών 

εκτεταμένης πραγματικότητας ήταν εστιασμένη στη τρισδιάστατη απεικόνιση και στην 

ελεύθερη περιήγηση. Ωστόσο, οι ποικίλες δυνατότητες και εμπειρίες που προσφέρουν οι 

εικονικοί κόσμοι, όπως η διαμόρφωση της ατομικής ταυτότητας μέσω της ενσάρκωσης, η 

διασύνδεση του εικονικού περιβάλλοντος με εξωτερικές πηγές, οι διάφορες μορφές 

επικοινωνίας και η ύπαρξη εικονικών κοινοτήτων, άρχισαν να διαφαίνονται με την πάροδο του 

χρόνου και διεύρυναν σε σημαντικό βαθμό την αξιοποίηση των συγκεκριμένων τεχνολογιών 

σε πληθώρα εκπαιδευτικών εφαρμογών. Οι εφαρμογές αυτές υπακούον στις σύγχρονες 



Χρήση σύγχρονων τεχνολογιών στην εκπαίδευση 

7 

εκπαιδευτικές θεωρίες και πρακτικές όπως η Εγκαθιδρυμένη μάθηση, ο Εποικοδομισμός, ο 

Κοινωνικός Εποικοδομισμός και ο Συμπεριφορισμός.   

2.3.1 Εγκαθιδρυμένη μάθηση 

Η προσέγγιση της εγκαθιδρυμένης μάθησης (Situated Learning) υποστηρίζει ότι το περιβάλλον 

μέσα στο οποίο διεξάγεται η διδασκαλία θα πρέπει να βρίσκεται σε πλήρη αντιστοιχία με το 

πραγματικό περιβάλλον του αντικειμένου μάθησης. Αυτό σημαίνει, σύμφωνα με τους 

θεωρητικούς της εγκαθιδρυμένης μάθησης, ότι το πλαίσιο διεξαγωγής της εκπαιδευτικής 

διαδικασίας σχετίζεται άμεσα με το μαθησιακό αποτέλεσμα και μπορεί τόσο να διευκολύνει 

όσο και να παρεμποδίσει ή να δυσκολέψει τη μάθηση [8]. Για παράδειγμα, δεν θα ήταν δυνατόν 

να μάθει κάποιος να οδηγεί αυτοκίνητο αποκλειστικά διαβάζοντας βιβλία ή βλέποντας σχετικά 

βίντεο. Αντίθετα, για να αποκτήσει κάποιος δεξιότητες οδήγησης θα πρέπει να εξασκηθεί σε 

ένα περιβάλλον που δείχνει και συμπεριφέρεται σαν το πραγματικό, όπως για παράδειγμα έναν 

προσομοιωτή, ή ακόμα καλύτερα να εξασκηθεί, με τη βοήθεια ενός εκπαιδευτή, σε πραγματικό 

αυτοκίνητο και σε πραγματικές συνθήκες. Γίνεται λοιπόν κατανοητό ότι οι εκπαιδευτικές 

τεχνολογίες εκτεταμένης πραγματικότητας θα μπορούσαν να αποτελέσουν ένα εξαιρετικά 

χρήσιμο εργαλείο για όλες εκείνες τις περιπτώσεις στις οποίες δεν είναι εφικτή για λόγους 

επικινδυνότητας, διαθεσιμότητας ή κόστους, η φυσική παρουσία του εκπαιδευόμενου στο 

πραγματικό πλαίσιο. Οι ρεαλιστικές αναπαραστάσεις και η εύκολη αλληλεπίδραση που 

προσφέρουν οι εικονικοί κόσμοι μπορούν να αποδώσουν το κατάλληλο περιβάλλον του 

εκάστοτε αντικειμένου μάθησης και με αυτό τον τρόπο να διευκολύνουν σημαντικά την 

μετάδοση της γνώσης.   

2.3.2 Εποικοδομισμός 

Η εκπαιδευτική θεωρία, στην οποία φαίνεται να βασίζονται κατά κύριο λόγο οι περισσότερες 

εκπαιδευτικές εφαρμογές εκτεταμένης πραγματικότητας είναι αυτή του εποικοδομισμού 

(Constructivism) [9]. Σύμφωνα με αυτή τη θεωρία, η μάθηση αποτελεί μία προοδευτική 

διαδικασία κατανόησης μέσα από την οποία το κάθε άτομο κατασκευάζει τη δική του μοναδική 

γνώση. Σε αντίθεση λοιπόν με την καθιερωμένη θεώρηση που αντιλαμβάνεται τη διδασκαλία 

σαν τη μετάδοση καθολικής γνώσης, ο εποικοδομισμός θεωρεί ότι η γνώση που αποκτούν οι 

άνθρωποι διαφοροποιείται ανάλογα με τις προηγούμενες εμπειρίες και θεωρήσεις του ατόμου 

και την αντίληψη που έχει για τον κόσμο. Η αξία και η βιωσιμότητα της εκάστοτε ατομικής 

γνώσης κρίνεται από τη λειτουργικότητα της σε σχέση με τις ευρύτερες ιδέες και πεποιθήσεις 

της κοινωνίας στην οποία ανήκει. Σε όλες τις διδακτικές προσεγγίσεις που βασίζονται στον 

εποικοδομισμό η έμφαση δίνεται σε δραστηριότητες μέσα από τις οποίες οι μαθητές 

ανακαλύπτουν μόνοι τους σταδιακά τη γνώση ως αποτέλεσμα της ενεργής τους συμμετοχής 

και ενασχόλησης, της συνεργασίας και της εξερεύνησης. Σε μία τέτοια κατεύθυνση 

διδασκαλίας οι εφαρμογές XR,VR,AR και MR αποτελούν ιδανική λύση καθώς απαιτούν την 

ενεργή συμμετοχή των μαθητών, προσφέρουν σημαντική ελευθερία για εξερεύνηση και 

αλληλεπίδραση με το περιβάλλον και τα αντικείμενα, παρατηρώντας ταυτόχρονα τα 

αποτελέσματα των ενεργειών τους, και τέλος δίνουν την ευκαιρία στους χρήστες να 

επικοινωνούν και να συνεργάζονται μεταξύ τους [10]. 
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2.3.3 Κοινωνικός Εποικοδομισμός 

Ο κοινωνικός εποικοδομισμός είναι μία θεωρία η οποία συνδέεται στενά τόσο με τον 

εποικοδομισμό όσο με την εγκαθιδρυμένη μάθηση που είδαμε προηγουμένως. Βασική ιδέα, 

υπό την οπτική του κοινωνικού εποικοδομισμού, αποτελεί η μαθητο-κεντρική ανάπτυξη της 

γνώσης εστιάζοντας όμως στη μάθηση ως μία κοινωνική διαδικασία και δίνοντας ιδιαίτερη 

έμφαση στη συνεργασία. Η μάθηση υπό το πρίσμα του κοινωνικού εποικοδομισμού βασίζεται 

στην ανάληψη διαφορετικών ρόλων. Με άλλα λόγια μαθαίνουμε δοκιμάζοντας και 

τροποποιούμε την προσέγγιση μας σύμφωνα με την ανάδραση που λαμβάνουμε από το 

περιβάλλον και τους άλλους και ξαναδοκιμάζουμε για να γίνουμε καλύτεροι [10]. Για 

παράδειγμα, για να γίνει κάποιος ένας καλός εκπαιδευτικός δεν αρκεί απλά να αναλάβει το 

ρόλο του καθηγητή αλλά οφείλει να δοκιμάσει και να εξελίξει τις διδακτικές του ικανότητες 

μέσα από την παρατήρηση και την συνεργασία με άλλους ανθρώπους που επιδιώκουν τον ίδιο 

σκοπό και υπό την καθοδήγηση έμπειρων εκπαιδευτικών οι οποίοι θα προσφέρουν την 

απαραίτητη ανατροφοδότηση. Η συγκεκριμένη θεωρία καθίσταται ιδιαίτερα δημοφιλής στους 

σχεδιαστές εφαρμογών XR,VR,AR και MR διότι οι συγκεκριμένες τεχνολογίες προσφέρουν 

τόσο την υποστήριξη κοινοτήτων μάθησης όσο και την δυνατότητα ανάληψης ρόλων, αλλά και 

της εκτέλεσης αυτών εντός ενός ρεαλιστικού πλαισίου. Επιπλέον, η σύγχρονη και ασύγχρονη 

επικοινωνία που προσφέρουν συντελεί και υποστηρίζει την ανάπτυξη και την ανάδυση 

κοινοτήτων.   

2.3.4 Συμπεριφορισμός 

Η θεωρία του συμπεριφορισμού στηρίζεται στην ιδέα ότι η συμπεριφορά μας διαμορφώνεται 

και μεταβάλλεται ανάλογα με τα ερεθίσματα που λαμβάνουμε από το περιβάλλον. Σύμφωνα 

λοιπόν με το μοντέλο διδασκαλίας του συμπεριφορισμού υπάρχει μία συγκεκριμένη 

συμπεριφορά η οποία αποτελεί στόχο και η οποία μπορεί να επιτευχθεί από τους 

εκπαιδευόμενους εάν τους παραχθούν τα κατάλληλα ερεθίσματα και οι κατάλληλες 

αποκρίσεις, τόσο αρνητικές όσο και θετικές, ανάλογα πάντα με τις επιδόσεις τους. Η 

συγκεκριμένη θεωρία έχει δεχθεί διάφορες κριτικές κυρίως γιατί υποστηρίζει την ύπαρξη μίας 

και μόνο επιθυμητής συμπεριφοράς και με αυτό τον τρόπο θεωρείται ότι οδηγεί στην παθητική 

μάθηση και βασίζεται στην απομνημόνευση. Ωστόσο είναι κοινώς αποδεκτή και κρίνεται 

απαραίτητη η ικανότητα του εκπαιδευόμενου να επιλύει κάποια σαφώς οριζόμενα προβλήματα 

τα οποία έχουν μία δεδομένη και αντικειμενική λύση, για παράδειγμα βασικές γνώσεις όπως 

το αλφάβητο και η προπαίδεια δεν θα ήταν εφικτό να μαθευτούν με κάποιον άλλο τρόπο από 

τα μικρά παιδιά εκτός από την απομνημόνευση [10]. Μία τέτοια κατεύθυνση διδασκαλίας θα 

μπορούσε να υποστηριχθεί από εφαρμογές XR,VR,AR και MR μέσα από ειδικά σχεδιασμένες 

εκπαιδευτικές δραστηριότητες και περιβάλλοντα εξάσκησης με προβλήματα αυξανόμενης 

δυσκολίας που θα παρέχουν άμεση αξιολόγηση των επιδόσεων των χρηστών και με την 

κατάλληλη ανάδραση ανά περίπτωση. Επιπλέον τα διάφορα παιγνιώδη χαρακτηριστικά που 

μπορούν να προσφέρουν οι συγκεκριμένες τεχνολογίες στις εκπαιδευτικές δραστηριότητες 

αυτές παρακινούν τόσο τη συμμετοχή των μαθητών αλλά και διατηρούν ζωντανό το 

ενδιαφέρον τους. Δραστηριότητες βασιζόμενες στον συμπεριφορισμό θα μπορούσαν να 
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εκτείνονται από απλά κουίζ και παιχνίδια γνώσεων έως εικονικούς εκπαιδευτές με ανθρώπινες 

μορφές που θα είναι σε θέση να επικοινωνούν και να αλληλοεπιδρούν με τους μαθητές στη 

φυσική τους γλώσσα [11].  

2.4 Πλεονεκτήματα Εκτεταμένης Πραγματικότητας στην εκπαίδευση 

Η ικανότητα των τεχνολογιών XR, VR, AR και MR να αναπαριστούν ρεαλιστικά ή υποθετικά 

περιβάλλοντα αλλά και η αλληλεπίδραση και επικοινωνία των χρηστών με αυτά προσφέρουν 

ποικίλα πλεονεκτήματα για την χρήση τους στην εκπαίδευση. Πρόκειται για ένα σύγχρονο 

μέσο που επιτρέπει τον σχεδιασμό και τη διαμόρφωση των κατάλληλων πλαισίων που με την 

ενσωμάτωση εκπαιδευτικών στοιχείων και την δημιουργία δραστηριοτήτων μπορούν να 

οδηγήσουν αποτελεσματικά στην μάθηση. Η μεγάλη ελευθερία επιλογών που προσφέρουν οι 

συγκεκριμένες τεχνολογίες κατά την σχεδίαση των εικονικών περιβαλλόντων αλλά και οι 

ποικίλες υποστηριζόμενες ενέργειες επιτρέπουν την υλοποίηση διάφορων εκπαιδευτικών 

δραστηριοτήτων και πρακτικών υποστηρίζοντας παράλληλα τις διάφορες εκπαιδευτικές 

προσεγγίσεις που προαναφέρθηκαν.  

Η σημαντικότερη ίσως συμβολή των τρισδιάστατων μαθησιακών περιβαλλόντων (3DLEs) 

είναι η καλύτερη κατανόηση και αφομοίωση των πολύπλοκων και αφηρημένων εννοιών και 

φαινομένων του περιεχομένου διδασκαλίας από τους μαθητές. Ως εκ τούτο, η χρήση των 

εικονικών κόσμων δύναται να συνεισφέρει αποτελεσματικά στην σύνθετη εννοιολογική 

μάθηση καθιστώντας τα εικονικά περιβάλλοντα ιδανικά πλαίσια μάθησης κυρίως για τη 

διδασκαλία των Φυσικών Επιστημών [12]. 

 Όπως είδαμε και παραπάνω σημαντικό εφόδιο για μία ποιοτική μάθηση αποτελεί επίσης η 

εμπειρική ενασχόληση των μαθητών με το αντικείμενο μελέτης. Ως εκ τούτου η 

παραστατικότητα και η ρεαλιστικότητα των εφαρμογών εκτεταμένης πραγματικότητας τις 

καθιστούν το ιδανικό εργαλείο μάθησης για όλες εκείνες τις περιπτώσεις όπου η φυσική 

παρουσία του μαθητευόμενου στο πραγματικό πλαίσιο μάθησης είναι αδύνατη. Στις 

περιπτώσεις δηλαδή που το γνωστικό αντικείμενο του μαθήματος περιλαμβάνει επικίνδυνες, 

ακατάλληλες ή ακόμη και αδύνατες διαδικασίες και συνθήκες. Επιπλέον, τα εικονικά 

περιβάλλοντα έχουν τη δυνατότητα να καλλιεργούν ρεαλιστικές συνθήκες μάθησης ακόμη και 

για κόσμους (μακρόκοσμους- μικρόκοσμους) που δεν είναι ορατοί από το ανθρώπινο μάτι 

χωρίς την κατοχή και τη χρήση ειδικών οργάνων. Επίσης, η χρήση των τεχνολογιών XR 

επιτρέπει την ασφαλή ενασχόληση των μαθητευόμενων με το αντικείμενο διδασκαλίας χωρίς 

να προκαλείται οποιαδήποτε καταστροφή ή ανεπανόρθωτη ζημία σε αυτό και χωρίς την 

ρύπανση του περιβάλλοντος [13]. 

Επιπρόσθετα, τα οπτικοακουστικά χαρακτηριστικά αλλά και οι απεριόριστες δυνατότητες 

αλληλεπίδρασής που παρέχουν τα περιβάλλοντα XR, VR, MR και AR προσφέρουν στους 

μαθητές και στους εκπαιδευτικούς μια διδακτική και μαθησιακή διαδικασία πιο ενδιαφέρουσα 

και διασκεδαστική  με μοναδικές εκπαιδευτικές δυνατότητες και εμπειρίες. Σε ένα τέτοιο 

εκπαιδευτικό πλαίσιο ενθαρρύνεται η ενεργή και όχι η παθητική συμμετοχή των μαθητών 

αλλάζοντας ριζικά τον τρόπο με τον οποίο οι μαθητές αλληλοεπιδρούν με το αντικείμενο 

μάθησης και διατηρώντας ταυτόχρονα αμείωτη την προσοχή και το ενδιαφέρον τους [12]. 
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Πέρα όπως από την καλύτερη δυνατότητα εξέτασης του μαθησιακού περιεχομένου, τα 

περιβάλλοντα προσομοίωσης παρέχουν επίσης ένα πολυαισθητηριακό πλαίσιο μάθησης. Τα 

αυθεντικά σενάρια και οι ρεαλιστικές απεικονίσεις μπορούν να δημιουργήσουν πραγματικές 

συνθήκες πίεσης προκαλώντας με αυτό τον τρόπο τα συναισθήματα του μαθητευόμενου και 

αναγκάζοντας τον να ενεργήσει. Ακόμα, δίνεται η δυνατότητα στον εκπαιδευόμενο να 

συμμετέχει στην εικονική εμπειρία με τους δικούς του ρυθμούς, αφήνοντας ανοιχτά χρονικά 

περιθώρια και ξεφεύγοντας με αυτό τον τρόπο από τα στενά πλαίσια που καθορίζει το σχολικό 

πρόγραμμα. Αξίζει επίσης να αναφερθεί πώς η χρήση εφαρμογών XR, VR, MR και AR στην 

διδασκαλία διευκολύνει την εξ’ αποστάσεως εκπαίδευση και συμβάλει στην ανάπτυξη 

διάφορων δεξιοτήτων όπως η συνεργασία, η δημιουργικότητα, η φαντασία κ.ά. Τέλος, η χρήση 

των παραπάνω τεχνολογιών θα ήταν ιδιαιτέρως χρήσιμη και στη διδασκαλία των ατόμων με 

ειδικές ανάγκες καθώς θα προσάρμοζε τη μαθησιακή διαδικασία στις εκάστοτε ανάγκες 

διδασκαλίας υποκαθιστώντας τις όποιες ικανότητες τους λείπουν ή τους δυσκολεύουν και 

επιτρέποντας τους με αυτό τον τρόπο να συμμετέχουν ενεργά στο μάθημα [12]. 

2.5 Η εφαρμογή PhysicX-R 

Όπως διαφαίνεται από την ανάλυση που πραγματοποιήσαμε στις προηγούμενες ενότητες η 

χρήση τεχνολογιών εκτεταμένης πραγματικότητας στην εκπαιδευτική διαδικασία προσφέρει 

ποικίλα πλεονεκτήματα και οφέλη τόσο για τους μαθητές όσο και για τους εκπαιδευτικούς. 

Μάλιστα τα τελευταία χρόνια παρατηρείται μία συνεχώς αυξανόμενη τάση στη χρήση 

εφαρμογών εικονικών κόσμων στην εκπαίδευση. Η εφαρμογή PhysicX-R  δημιουργήθηκε με 

σκοπό να συμβάλει δυναμικά στην προσαρμογή της εκπαιδευτικής διαδικασίας στις απαιτήσεις 

της σύγχρονης εποχής και στην ενσωμάτωση των νέων αυτών τεχνολογιών στις σύγχρονες 

εκπαιδευτικές μεθόδους και δραστηριότητες με σκοπό την απομάκρυνση από τα παραδοσιακά 

δασκαλοκεντρικά μοντέλα διδασκαλίας και τη δημιουργία μιας εκπαιδευτικής διαδικασίας 

εστιασμένης στους μαθητές μέσα από την πρακτική άσκηση και τις εμπράγματες εμπειρίες.  

Με την χρήση της εφαρμογής PhysicX-R τα παραδοσιακά σχολικά εγχειρίδια αλλάζουν μορφή 

και ζωντανεύουν τρισδιάστατα το περιεχόμενο τους μέσα από τις οθόνες φορητών συσκευών. 

Ο εκπαιδευτικός έχει την ευκαιρία να αξιοποιήσει αυτή την καινοτόμο μέθοδο διδασκαλίας και 

να διευκολύνει σημαντικά την εκμάθηση και την κατανόηση των δύσκολων εννοιών και των 

πολύπλοκων φαινομένων του μαθήματος Φυσικά Δημοτικού – Ερευνώ και Ανακαλύπτω της 

ΣΤ’ τάξης. Επιπλέον, η εφαρμογή PhysicX-R, μέσα από τα παιγνιώδη χαρακτηριστικά που 

διαθέτει, στοχεύει στη διατήρηση του ενδιαφέροντος των μαθητών και στη δημιουργία μιας 

πιο ευχάριστης και διασκεδαστικής εκπαιδευτικής διαδικασίας που θα παρακινεί τους μαθητές 

να συμμετέχουν ενεργά στο μάθημα αλλά και να συνεργάζονται αρμονικά με μεγαλύτερη 

αυτονομία και ακολουθώντας τους δικούς τους ρυθμούς. Ολοκληρώνοντας αξίζει να 

αναφέρουμε ότι εκτός από τα καλύτερα μαθησιακά αποτελέσματα, η χρήση της εφαρμογής 

PhysicX-R επιδιώκει επίσης να συμβάλει στην ανάπτυξη διάφορων δεξιοτήτων των μαθητών 

όπως η συνεργασία, η δημιουργικότητα, η φαντασία κ.ά.  
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2.6 Επίλογος 

Μετά την ανάλυση των τεχνολογιών εκτεταμένης πραγματικότητας και των δυνατοτήτων τους 

καθώς της μελέτης των σύγχρονων εκπαιδευτικών προσεγγίσεων που πραγματοποιήσαμε, 

καθίσταται σαφής η ανάγκη αξιοποίησης τους στα σύγχρονα εκπαιδευτικά συστήματα. 
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Κεφάλαιο 3ο: Εγκατάσταση Unity και ρυθμίσεις πλατφόρμας 

3.1 Εισαγωγή 

Στον παρόν κεφάλαιο παρουσιάζονται αναλυτικά όλα τα βήματα που ακολουθήθηκαν για την 

εγκατάσταση των Unity Hub και Unity, καθώς και οι βασικές ρυθμίσεις όλων των παραμέτρων 

της πλατφόρμας. 

3.2 Επιλογή πλατφόρμας 

Η Unity αποτελεί την πιο διαδεδομένη πλατφόρμα ανάπτυξης βιντεοπαιχνιδιών στον κόσμο. 

Οι κυριότεροι λόγοι για τους οποίους επιλέχθηκε η συγκεκριμένη πλατφόρμα για τη 

δημιουργία του παιχνιδιού της παρούσας εργασίας είναι αρχικά οι ποικίλες δυνατότητες που 

προσφέρει εντελώς δωρεάν, καθώς και η ύπαρξη συνεχώς αναπτυσσόμενων βιβλιοθηκών, 

όπως η Vuforia που χρησιμοποιήθηκε εκτενώς κατά τη δημιουργία της παρούσας εφαρμογής 

και προσφέρεται επίσης δωρεάν. Επιπλέον, η συγκεκριμένη πλατφόρμα διαθέτει ένα Asset 

store που προσφέρει αρκετά γραφικά μοντέλα και στοιχεία έτοιμα προς χρήση. Τέλος, υπάρχει 

μία σημαντική κοινότητα χρηστών στο support.unity.com που προσφέρει άμεση βοήθεια και 

υποστήριξη. Η γλώσσα προγραμματισμού που υποστηρίζει η Unity είναι η C# και για την 

συγγραφή των scripts χρησιμοποιήθηκε η πλατφόρμα Visual Studio. 

3.3 Εγκατάσταση Unity Hub, Unity και ρυθμίσεις SDK- JDK- NDK 

Αρχικά πραγματοποιήθηκε η εγκατάσταση του Unity Hub (έκδοση 2.3.0), το οποίο παρέχει τη 

δυνατότητα επιλογής μεταξύ των διάφορων εκδόσεων της Unity καθώς και την εύκολη και 

ολοκληρωμένη εγκατάσταση όλων των κύριων βιβλιοθηκών της εκάστοτε έκδοσης. Η έκδοση 

που επιλέχθηκε είναι η 2019.4.23f1 διότι παρέχει προ εγκατεστημένο το πακέτο Vuforia και 

την βιβλιοθήκη Vuforia Engine, τα οποία επιτρέπουν την ανάπτυξη εφαρμογών επαυξημένης 

πραγματικότητας. Στην συνέχεια πατώντας “New” και συμπληρώνοντας τις απαραίτητες 

πληροφορίες ολοκληρώνεται η δημιουργία του νέου project από το κουμπί “Create Project”. 

Σε αυτό το σημείο έχει δημιουργηθεί ένα βασικό Unity 3D Project, το οποίο περιέχει μόνο δύο 

αντικείμενα τα “Main Camera” και “Directional Light”. 

Μετά την δημιουργία του νέου Project ακολούθησε η ρύθμιση των βασικών παραμέτρων. Η 

Unity παρέχει προεπιλεγμένα τα Android Software Development Kit (SDK), Java 

Development Kit (JDK) και Native Development Kit (NDK), τα οποία ωστόσο χρειάστηκε να 

αντικατασταθούν καθώς παρουσίαζαν προβλήματα συμβατότητας. Η αλλαγή των 

συγκεκριμένων εργοστασιακών ρυθμίσεων έγινε από Edit → Preferences → External tools → 

Android, όπως φαίνεται στην εικόνα 3.1. 
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Εικόνα 3.1: Αλλαγή ρυθμίσεων SDK- JDK- NDK 

3.4 Unity Package Manager 

Στη συνέχεια πραγματοποιήθηκε η επιλογή και η εγκατάσταση των κατάλληλων πακέτων, τα 

οποία κρίθηκαν απαραίτητα για τη δημιουργία του παιχνιδιού. Η εγκατάσταση των 

συγκεκριμένων πακέτων έγινε μέσω του Unity Package Manager, το οποίο βρίσκεται στο 

Window→ Package Manager. Το Package Manager, το οποίο παρουσιάστηκε πρώτη φορά 

στην έκδοση Unity 2017.2, αποτελεί ένα αρθρωτό σύστημα που επιτρέπει στον χρήστη να δει 

τόσο τα εγκατεστημένα πακέτα του project όσο και όλα τα διαθέσιμα πακέτα προς 

εγκατάσταση. Επιπρόσθετα, από το συγκεκριμένο παράθυρο ο χρήστης μπορεί να φορτώσει, 

να καταργήσει ή να ενημερώσει τα πακέτα του έργου του. Τα πακέτα που επιλέχθηκαν για το 

παρόν project ήταν τα AR Foundation 2.1.18, XR Interaction Subsystems 1.0.1, ProBuilder 

4.5.0, TextMeshPro 2.1.1 και Vuforia Engine AR 8.5.9. Επιπλέον, από τα προ εγκατεστημένα 

πακέτα χρησιμοποιήθηκαν τα Visual Studio Code Editor 1.2.3, Unity UI 1.0.0 και Test 

FrameWork 1.1.22. 

3.4.1 AR Foundation  

To AR Foundation (Εικόνα 3.2) αποτελεί ένα πακέτο το οποίο επιτρέπει τη δημιουργία 

εφαρμογών επαυξημένης πραγματικότητας και υποστηρίζει διάφορα πακέτα AR για τη 

δημιουργία εφαρμογών συμβατών τόσο σε IOS όσο και σε Android συσκευές. Αυτό σημαίνει 

ότι ο ίδιος κώδικας μπορεί να χρησιμοποιηθεί απαράλλακτος και για τα δύο λογισμικά. Τέλος, 

το συγκεκριμένο πακέτο καθίσταται ιδιαίτερα λειτουργικό για τον χρήστη καθώς προσφέρει 

την δυνατότητα ταυτόχρονης δημιουργίας και προβολής. 
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Εικόνα 3.2: AR Foundation 

 

3.4.2 XR Interaction Subsystems 

Το XR Interaction Subsystems (Εικόνα 3.3) είναι ένα αρκετά πρόσφατο πακέτο, καθώς 

κυκλοφόρησε στα τέλη του 2019, και περιέχει όλα εκείνα τα υποσυστήματα τα οποία 

επιτρέπουν την αλληλεπίδραση μεταξύ του χρήστη και των αντικείμενων του εικονικού 

κόσμου. Με άλλα λόγια, το συγκεκριμένο πακέτο είναι υπεύθυνο για την λειτουργικότητα της 

αλληλεπίδρασης και μέσω αυτού μπορούμε να ορίσουμε τι αποτέλεσμα θα προκαλέσει στα 

αντικείμενα του κόσμου επαυξημένης πραγματικότητας η κάθε πιθανή ενεργεία του χρήστη.    
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Εικόνα 3.3: XR Interaction Subsystems 

3.4.3 ProBuilder 

Το ProBuilder (Εικόνα 3.4) είναι ένα πακέτο το οποίο προσφέρει τη δυνατότητα σχεδιασμού 

επιπέδων και τρισδιάστατης μοντελοποίησης με έναν ιδιαίτερα εύκολο και προσιτό προς τον 

χρήστη τρόπο. Μέσω οπτικού προγραμματισμού και με τη χρήση τόσο έτοιμων όσο και εύκολα 

τροποποιήσιμων μοντέλων επιτυγχάνεται η κατασκευή αντικειμένων απλής γεωμετρίας, η 

δημιουργία πρωτότυπων δομών, χαρακτηριστικών εδάφους καθώς επίσης και πιο σύνθετων 

αντικειμένων όπως οχήματα και όπλα. Επιπλέον, το συγκεκριμένο πακέτο σε συνδυασμό με 

άλλα ψηφιακά εργαλεία δημιουργίας περιεχομένου, όπως το Maya, επιτρέπει την περαιτέρω 

λεπτομερή επεξεργασία και λείανση των αντικειμένων με τα εργαλεία που παρέχει.   
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Εικόνα 3.4: ProBuilder 

3.4.4 TextMeshPro 

Το TextMeshPro (Εικόνα 3.5), το οποίο αντικατέστησε το Unity’s UI Text και το Text Mesh,  

είναι το απόλυτο πακέτο κειμένου της Unity. Το TextMeshPro, γνωστό και ως TMP, παρέχει 

μία τεράστια ποικιλία επιλογών ως προς το στυλ και την υφή του κειμένου. Με τη χρήση 

προηγμένων τεχνικών απόδοσης κειμένου και πολλαπλών επιλογών σκίασης προσφέρει μία 

σημαντικά βελτιστοποιημένη οπτική ποιότητα στο κείμενο. Επιπρόσθετα, παρέχει πλήρη 

έλεγχο στο χρήστη τόσο για τη μορφοποίηση όσο και για την διάταξη του κειμένου μέσα από 

μία μεγάλη γκάμα χαρακτήρων, λέξεων, συνδέσμων, διαστημάτων και στοίχισης σειρών και 

παραγράφων, καθώς και πάνω από 30 επιλογές εμπλουτισμένου κειμένου και υποστήριξη 

πολλαπλών γραμματοσειρών και στυλ. Ωστόσο, παρά τις ποικίλες επιλογές που προσφέρει και 

την βελτιωμένη οπτική ποιότητα δεν επιφέρει επιπλέον κόστος απόδοσης. Τέλος, αξίζει να 

σημειωθεί ότι το TMP αποδείχθηκε ένα αρκετά χρήσιμο εργαλείο κατά το σχεδιασμό του 

παρόντος project διότι επέτρεψε τη χρήση ελληνικής γραμματοσειράς.  
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Εικόνα 3.5: TextMeshPro 

3.4.5 Vuforia Engine AR 

Το Vuforia Engine AR (Εικόνα 3.6) είναι το πλέον απαραίτητο πακέτο για την ανάπτυξη 

εφαρμογών επαυξημένης πραγματικότητας για κινητά τηλέφωνα, tablets καθώς και γυαλιά VR. 

Το συγκεκριμένο πακέτο δίνει τη δυνατότητα εύκολης προσθήκης προηγμένων λειτουργιών 

υπολογιστικής όρασης δημιουργώντας πρωτόγνωρες εμπειρίες επαυξημένης πραγματικότητας 

που επιτρέπουν ρεαλιστικές αλληλεπιδράσεις τόσο με τα αντικείμενα όσο και με το 

περιβάλλον. Το Vuforia Engine υποστηρίζει την ανάπτυξη εφαρμογών AR για συσκευές 

Android, iOS, Lumin και UWP. Επιπλέον, ένα από τα σημαντικότερα πλεονεκτήματα του εν 

λόγο πακέτου είναι η παράλληλη υποστήριξη που παρέχεται στους προγραμματιστές μέσω της 

ιστοσελίδας [14], η οποία ενημερώνεται συνεχώς με οδηγούς και πληροφορίες σχετικά με τις 

πιο πρόσφατες δυνατότητες και υπηρεσίες του πακέτου. Επίσης, η συγκεκριμένη ιστοσελίδα  

διαθέτει ένα ενεργό forum επικοινωνίας όπου οι χρήστες έχουν την δυνατότητα να συνομιλούν 

τόσο με μέλη του Vuforia Innovator Program όσο και με άλλους χρήστες για οποιαδήποτε 

επιπλέον πληροφορία και βοήθεια. Επιπρόσθετα, μία ακόμη αρκετά χρήσιμη δυνατότητα του 

Vuforia Egnine είναι η εύκολη εμφάνιση περιεχομένου επαυξημένης πραγματικότητας μέσω 

της αναγνώρισης qrcodes. Τέλος, αξίζει να αναφερθεί πως όλες οι παραπάνω δυνατότητες 

κατέστησαν το Vuforia Egnine ιδιαίτερα χρήσιμο και απαραίτητο για την ανάπτυξη του 

παρόντος project.  
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Εικόνα 3.6: Vuforia Engine AR 

 

3.4.6 Visual Studio Code Editor 

Το Visual Studio Code Editor (Εικόνα 3.7) είναι μια δωρεάν επέκταση που παρέχεται μέσω 

του Unity και επιτρέπει τη χρήση ενός πολύ ισχυρού εργαλείου για την ανάπτυξη παιχνιδιών 

και εφαρμογών. Ενώ ο επεξεργαστής του Unity είναι εξαιρετικός για να συνδυάσει τον κόσμο 

ενός παιχνιδιού ή μίας εφαρμογής, δεν επιτρέπει την συγγραφή κώδικά σε αυτό. Ωστόσο με το 

Visual Studio Code Editor, δίνεται η δυνατότητα χρησιμοποίησης των γνωστών δυνατοτήτων 

επεξεργασίας κώδικα, εντοπισμού σφαλμάτων και παραγωγικότητας του Visual Studio για τη 

δημιουργία προγραμμάτων επεξεργασίας και σεναρίων παιχνιδιών για οποιοδήποτε project 

Unity χρησιμοποιώντας C# και εντοπίζοντας τυχόν σφάλματα χρησιμοποιώντας τις ισχυρές 

δυνατότητες εντοπισμού σφαλμάτων του Visual Studio. 
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Εικόνα 3.7: Visual Studio Code Editor 

3.4.7 Unity UI 

Το Unity UI (Εικόνα 3.8) είναι μία εργαλειοθήκη UI για την ανάπτυξη διεπαφών χρήστη σε 

παιχνίδια και εφαρμογές. Είναι ένα σύστημα που βασίζεται στο GameObject και χρησιμοποιεί 

περιεχόμενα και Game View για να τακτοποιήσει, να τοποθετήσει και να σχεδιάσει τις 

επιθυμητές διεπαφές χρήστη. Μερικές από τις λειτουργίες του Unity UI είναι η δημιουργία 

καμβά, η τοποθέτηση και η εμψύχωση στοιχείων, ο ορισμός των αλληλεπιδράσεων των 

χρηστών και οι ρυθμίσεις εμφάνισης των layouts.  
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Εικόνα 3.8: Unity UI 

3.4.8 Test FrameWork 

Το Test FrameWork (Εικόνα 3.9), ή αλλιώς UTF, είναι μια προσαρμοσμένη και πιο 

περιγραφική ονομασία για το σύνολο εργαλείων που αλλιώς είναι γνωστό ως Unity Test 

Runner, το οποίο είναι τώρα διαθέσιμο εντός του συγκεκριμένου πακέτου. Το Unity Test 

Framework δίνει τη δυνατότητα στους χρήστες της Unity να δοκιμάσουν τον κώδικά τους τόσο 

στη Λειτουργία Επεξεργασίας όσο και στη Λειτουργία Αναπαραγωγής, καθώς και σε 

πλατφόρμες όπως Android, iOS κ.λπ. Πιο συγκεκριμένα το πακέτο αυτό παρέχει ένα τυπικό 

πλαίσιο δοκιμών για τους χρήστες της Unity χρησιμοποιώντας μια ενοποίηση της βιβλιοθήκης 

NUnit, η οποία είναι μια βιβλιοθήκη δοκιμής μονάδας ανοιχτού κώδικα για .Net γλώσσες. 

Τέλος, το UTF χρησιμοποιεί αυτήν τη στιγμή την έκδοση NUnit 3.5. 
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Εικόνα 3.9: Test Framework 

3.5 Build Settings της εφαρμογής PhysicX-R 

Οι βασικές ρυθμίσεις για τη δημιουργία της παρούσας εφαρμογής μπορούν να χωριστούν σε 

δύο τμήματα, τις ρυθμίσεις παίκτη και τις ρυθμίσεις σκηνών. Όσον αφορά τις ρυθμίσεις του 

παίκτη, αυτές πραγματοποιήθηκαν από το unity → File → Build settings και στη συνέχεια από 

την καρτέλα που εμφανίστηκε επιλέχθηκε Player settings → Player → Other settings. Οι 

ρυθμίσεις που πραγματοποιήθηκαν σε αυτό το σημείο φαίνονται στην εικόνα 3.10. Αρχικά 

απενεργοποιήθηκε το Multithreaded Rendering λόγω προβλημάτων που εντοπίστηκαν κατά τη 

μεταφορά του αρχείου μορφής .apk στη συσκευή κινητού τηλεφώνου. Στο πεδίο Identification 

το Package Name συμπληρώθηκε αυτόματα με τη μορφή com.ptuxiakh.peirama από τα 

στοιχεία που είχαν δοθεί κατά τη δημιουργία του project στα πεδία Company Name και Product 

Name. Τέλος, από το πεδίο Identification επιλέχθηκε στο Minimum API Level το Android 5.0 

‘Lollipop’ (API level 21) καθώς πρόκειται για το υποχρεωτικά χαμηλότερο API Level που 

μπορεί να υποστηρίξει το Vuforia Engine AR. 
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Εικόνα 3.10: Οι ρυθμίσεις του παίκτη 

 

Το δεύτερο τμήμα των Build Settings αφορά, όπως προαναφέρθηκε, τις σκηνές. Οι συνολικές 

σκηνές του παιχνιδιού είναι είκοσι μία. Η πρώτη σκηνή αφορά την αρχική σκηνή του βασικού 

κορμού και ονομάστηκε arxikh. Οι υπόλοιπες σκηνές του παιχνιδιού ακολουθούν μία 

συγκεκριμένη μορφή ονομασίας. Το κάθε ένα από τα τέσσερα συνολικά κεφάλαια που 

περιέχονται στην εφαρμογή αποτελείται από πέντε σκηνές, για τις οποίες ακολουθήθηκε η ίδια 

ονομασία με μόνη διαφορά την αρίθμηση 1,2,3,4 που αναφέρεται στο εκάστοτε κεφάλαιο. Το 

κεφάλαιο ΘΕΡΜΟΤΗΤΑ περιέχει τις σκηνές epilogh_1, paixnidi_1, perigrafh_peiramatos_1, 

peirama_1 και symperasma_1. Αντίστοιχα το κεφάλαιο ΗΛΕΚΤΡΟΜΑΓΝΗΤΙΣΜΟΣ περιέχει 

τις σκηνές epilogh_2, paixnidi_2, perigrafh_peiramatos_2, peirama_2 και symperasma_2. Το 

κεφάλαιο ΦΩΣ περιέχει τις σκηνές epilogh_3, paixnidi_3, perigrafh_peiramatos_3, peirama_3 

και symperasma_3. Και τέλος, το κεφάλαιο ΟΞΕΑ-ΒΑΣΕΙΣ-ΑΛΑΤΑ περιέχει τις σκηνές 

epilogh_4, paixnidi_4, perigrafh_peiramatos_4, peirama_4 και symperasma_4. Η ιεραρχία και 

οι ονομασίες των σκηνών φαίνονται στην εικόνα 3.11. 
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Εικόνα 3.11: Η ιεραρχία των σκηνών της εφαρμογής 

3.6 Ρυθμίσεις κινητού 

Αφού ολοκληρώθηκαν οι παραπάνω ρυθμίσεις, στη συνέχεια πραγματοποιήθηκαν οι 

απαραίτητες ρυθμίσεις στη συσκευή κινητού τηλεφώνου για να επιτραπεί η εγκατάσταση και 

η λειτουργία της εφαρμογής επαυξημένης πραγματικότητας. Η συσκευή που χρησιμοποιήθηκε 

είναι η Samsung A8 2018.  Αρχικά για να “ξεκλειδωθεί” στις ρυθμίσεις κινητού η επιλογή 

«Επιλογές προγραμματιστή» χρειάστηκε να πραγματοποιηθούν τα εξής βήματα:  Ρυθμίσεις 

κινητού → Πληροφορίες για το κινητό → Πληροφορίες για το λογισμικό, στη συνέχεια 

χρειάστηκε να πατήσουμε εφτά φορές συνεχόμενα πάνω στην επιλογή «Αριθμός κατασκευής» 

και αφού συμπληρώθηκε το PIN της συσκευής ολοκληρώθηκε η διαδικασία. Από το μενού 

«Επιλογές προγραμματιστή», το οποίο πλέον εμφανίζεται στο τέλος των ρυθμίσεων του 

κινητού ενεργοποιούμε την επιλογή «Εντοπισμός σφαλμάτων USB». Μετά το πέρας των 

παραπάνω ρυθμίσεων εγκαταστάθηκαν στη συσκευή μέσω του Play Store η εφαρμογή 

Υπηρεσίες Google Play για AR και η εφαρμογή Unity Remote 5. 

Στη συνέχεια, πραγματοποιήθηκε η σύνδεση του κινητού τηλεφώνου με τον υπολογιστή μέσω 

καλωδίου USB και έγιναν οι εξής ρυθμίσεις στο πρόγραμμα Unity για την αναγνώριση της 

συσκευής: Edit → Project settings → Editor και από την κατηγορία Unity Remote επιλέχθηκε 

στο πεδίο Device η επιλογή Any Android Device όπως φαίνεται στην εικόνα 3.12. 
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Εικόνα 3.12: Σύνδεση με Android device 

Σε αυτό το σημείο θα πρέπει να εμφανίζεται η ονομασία της συσκευής στο πεδίο Run Device 

το οποίο βρίσκεται στο File→ Build settings → Android. Αφού επιλεχθεί η συσκευή όπως 

φαίνεται στην εικόνα 3.13  και πατώντας Build and Run ολοκληρώνεται η εγκατάσταση του 

project στην συσκευή κινητού τηλεφώνου.   

 

Εικόνα 3.13: Επιλογή συσκευής κινητού 

 

3.7 Ρυθμίσεις AR 

Το πρώτο στάδιο των ρυθμίσεων AR του project είναι η δημιουργία μίας κάμερας επαυξημένης 

πραγματικότητας, δηλαδή η δημιουργία ενός αντικειμένου το οποίο θα χρησιμοποιηθεί ως AR 

Camera. Η παραπάνω ρύθμιση πραγματοποιήθηκε με τα εξής βήματα: Game Object → Vuforia 

Engine → AR Camera και στην συνέχεια Game Object → XR → AR Session. Μετά την 

ολοκλήρωση της δημιουργίας της AR Camera προχωρήσαμε στην απενεργοποίηση της Main 

Camera και στην συνέχεια επιλέχθηκε η AR Camera ως Main Camera. Τέλος, για την σωστή 

λειτουργία της AR Camera χρειάστηκαν να γίνουν οι παραμετροποιήσεις που εμφανίζονται 

στην εικόνα 3.14 από το μενού Window → Vuforia Configuration και η προσθήκη του Vuforia 
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Behaviour (Script) από το Add Component στην AR Camera, από το οποίο επιλέχθηκε στο 

πεδίο World Center Mode η επιλογή DEVICE, όπως φαίνεται στην εικόνα 3.15 

 

Εικόνα 3.14: Ρυθμίσεις AR Camera 1 

 

 

Εικόνα 3.15: Ρυθμίσεις AR Camera 2 
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Μετά το πέρας των παραπάνω ρυθμίσεων και για την ενεργοποίηση του Vuforia Engine στο 

Unity απαιτείται η εισαγωγή ένος licence key για την δημιουργία του οποίου ακολουθήθηκαν 

τα εξής βήματα: ARCamera → Inspector → Vuforia Behaviour (Script) → Open Vuforia 

Engine configuration → Global → App License Key, και κάνοντας κλικ στο κουμπί Add 

License μεταφερόμαστε αυτόματα στην επίσημη ιστοσελίδα του Vuforia Engine [14] όπου 

δημιουργήσαμε έναν προσωπικό λογαριασμό από το Develop → License Manager → Get 

Development Key (Εικόνα 3.16).  

 

 

Εικόνα 3.16: Δημιουργία License Key 

Αφού δόθηκε ένα όνομα για το κλειδί στο πεδίο License Name και αποδεχθήκαμε τους όρους 

του Vuforia Developer Agreement ολοκληρώθηκε η διαδικασία δημιουργίας του κλειδιού και 

εμφανίστηκε το Licence Key, το οποίο αντιγράφηκε και επικολλήθηκε εντός του Unity στο 

πεδίο App License Key ακολουθώντας τα βήματα ARCamera → Vuforia Behaviour (Script) 

→ Open Vuforia Engine configuration → Global, όπως φαίνεται στην εικόνα 3.17. 

 

Εικόνα 3.17: Προσθήκη License Key 
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3.8 Δημιουργία QRcodes και εισαγωγή σε Unity 

Τα QRcodes είναι barcode γραμμωτού κώδικα και δύο διαστάσεων τα οποία 

πρωτοεμφανίστηκαν στα μέσα της δεκαετίας του ’90. Συνήθως τα QRcodes χρησιμοποιούνται 

ως ένα εξαιρετικό σημείο εκκίνησης για την αναγνώριση και την επαύξηση περιεχομένου 

τυπωμένων μέσων για διαφημιστικές καμπάνιες, παιχνίδια, εκπαιδευτικές εφαρμογές κ.ά. Το 

Vuforia Engine έχει την δυνατότητα να ανιχνεύει και να παρακολουθεί τις εικόνες που 

αντιπροσωπεύουν τα QRcodes και να επαυξάνει απρόσκοπτα το περιεχόμενου τους 

χρησιμοποιώντας μία από τις καλύτερες και πιο σύγχρονες τεχνολογίες image tracking. 

Τα QRcodes μπορούν να χρησιμοποιήσουν οποιαδήποτε επίπεδη εικόνα που παρέχει επαρκείς 

λεπτομέρειες για ανίχνευση και μπορούν να δημιουργηθούν χρησιμοποιώντας  εικόνες JPG, 

PNG σε RGB ή κλίμακα του γκρι. Ωστόσο, το μέγεθος των εικόνων εισόδου δεν πρέπει να 

ξεπερνά τα 2,25 ΜΒ και το πλάτος τους θα πρέπει να είναι τουλάχιστον 320 pixels για να 

μπορούν να ανιχνευθούν από το Vuforia Engine. Τέλος, αξίζει να σημειωθεί ότι η ανάγνωση 

των QRcode μπορεί να επηρεαστεί από τυχόν γυαλάδες και αντανακλάσεις που δημιουργούν 

οι διάφορες πήγες φωτισμού. Για τον λόγο αυτό οι ιδανικές συνθήκες που προτείνονται για την 

ανάγνωση τους είναι ο ομοιόμορφος και διάχυτος φωτισμός σε συνδυασμό με μία σχετικά 

μέτρια φωτεινότητα.   

Για το παρόν project χρειάστηκε η δημιουργία τεσσάρων QRcodes, η οποία πραγματοποιήθηκε 

μέσω της ιστοσελίδας “shawnlehner” [15]. To συγκεκριμένο online generator παρέχει τη 

δυνατότητα δημιουργίας QRcodes υψηλής ορατότητας με πολλά διαθέσιμα σημεία 

παρακολούθησης για βιβλιοθήκες που βασίζονται σε Vuforia ή ARToolkit. Η βιβλιοθήκη που 

χρησιμοποιούμε στο παρόν παιχνίδι είναι η Vuforia οπότε τα βήματα που ακολουθήθηκαν ήταν 

Vuforia → download και στη συνέχεια Re-generate άλλες τρείς φορές (Εικόνα 3.18). 
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Εικόνα 3.18: Δημιουργία QRcodes 

Τα τέσσερα συνολικά QRcodes που χρησιμοποιήθηκαν στην εφαρμογή PhysicX-R φαίνονται 

στην εικόνα 3.19. 
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Εικόνα 3.19: QRcodes εφαρμογής 

 

Μετά την ολοκλήρωση της δημιουργίας των QRcodes, είναι απαραίτητη για την εισαγωγή τους 

στο Unity η δημιουργία μιας βάσης δεδομένων. Η δημιουργία αυτής της βάσης 

πραγματοποιήθηκε μέσω της επίσημης ιστοσελίδας του Vuforia Engine [14], στην οποία 

ακολουθήθηκαν τα εξής βήματα Develop → Target Manager → Database, όπως φαίνεται και 

στην εικόνα 3.20. 



Εγκατάσταση Unity και ρυθμίσεις πλατφόρμας 

31 

 

Εικόνα 3.20: Δημιουργία Database 

 

Στη συνέχεια στο παράθυρο που εμφανίζεται συμπληρώσαμε το όνομα της βάσης που μόλις 

δημιουργήσαμε και αφήνοντας την προεπιλογή DEVICE στο πεδίο type επιλέξαμε Create. 

Κάνοντας κλικ πάνω στο όνομα της βάσης δεδομένων μας, η οποία τώρα εμφανίζεται στο 

μενού Target Manager, και στην συνέχεια στο πεδίο Add target προσθέσαμε τα QRcodes ένα 

ένα, επιλέγοντας single image στο πεδίο type και συμπληρώνοντας 1 στο πεδίο Width. Αφού 

ολοκληρώθηκε η εισαγωγή των QRcodes στη βάση δεδομένων, για την εξαγωγή της 

επιλέχθηκε Download database all και αφού επιλέξαμε Unity Editor ως development platform 

πατήσαμε download (Εικόνα 3.21).  

 

Εικόνα 3.21: Εξαγωγή Database 

Τέλος, για την εισαγωγή της βάσης στο Unity ακολουθήθηκαν τα εξής βήματα εντός του 

προγράμματος: Assets → Import Package → Custom Package, στην συνέχεια επιλέχθηκε το 

αρχείο της βάσης που κατεβάσαμε προηγουμένως και πατώντας άνοιγμα ολοκληρώθηκε η 

διαδικασία εισαγωγής. Η βάση δεδομένων με τα QRcodes της εφαρμογής είναι έτοιμη προς 

χρήση και θα αξιοποιηθεί στην συνέχεια κατά την δημιουργία των παιχνιδιών.  

3.9 Επίλογος 

Μετά την ολοκλήρωση των βασικών ρυθμίσεων και την εισαγωγή της βάσης δεδομένων των 

QRcodes στην πλατφόρμα όλα είναι έτοιμα για τη δημιουργία των σκηνών της εφαρμογής. 
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Κεφάλαιο 4ο: Βασικό μενού παιχνιδιού 

4.1 Εισαγωγή 

Το παρόν κεφάλαιο αναφέρεται στην επιλογή των πειραμάτων που θα εμφανίζονται στην 

εφαρμογή καθώς και στην αναλυτική περιγραφή της βασικής σκηνής του παιχνιδιού, δηλαδή 

του κεντρικού μενού, καθώς και του κεντρικού χαρακτήρα του παιχνιδιού.  

4.2 Επιλογή πειραμάτων 

Το εκπαιδευτικό υλικό το οποίο που χρησιμοποιήθηκε για την δημιουργία του παιχνιδιού 

επαυξημένης πραγματικότητας προέρχεται από το Τετράδιο εργασιών ΣΤ’ τάξης του 

μαθήματος Φυσικά Δημοτικού – Ερευνώ και Ανακαλύπτω. Σύμφωνα με τις οδηγίες 

διαχείρισης της ύλης για την σχολική χρονιά 2020-2021 τα κεφάλαια «Φυτά», «Ζώα» και 

«Οικοσύστημα» βρίσκονται εκτός διδακτέας ύλης. Από τα εναπομείναντα κεφάλαια 

επιλέχθηκε ένα πείραμα από κάθε κεφάλαιο για υλοποίηση μέσω του παιχνιδιού επαυξημένης 

πραγματικότητας εκτός από τα κεφάλαια «Έμβιά-Άβια», «Μεταδοτικές ασθένειες» και 

«Αναπαραγωγικό σύστημα» τα οποία δεν περιέχουν πειραματικές ασκήσεις. Επίσης, εκτός του 

παιχνιδιού θα παραμείνουν και τα κεφάλαια «Αναπνευστικό σύστημα» και «Κυκλοφορικό 

σύστημα» καθώς τα πειράματα που περιέχουν είναι βιωματικά και απαιτούν αποκλειστικά 

φυσική παρουσία. Τέλος, το κεφάλαιο «Ενέργεια» περιλαμβάνει ένα και μόνο πείραμα το 

οποίο είναι εκτός της διδακτέας ύλης. Πιο συγκεκριμένα, τα πειράματα τα όποια θα 

υλοποιηθούν μέσω του παιχνιδιού επαυξημένης πραγματικότητας θα είναι το πείραμα της 

σελίδας 52 από την ενότητα ΦΕ1 του κεφαλαίου «Θερμότητα». Από το κεφάλαιο 

«Ηλεκτρομαγνητισμός» θα υλοποιηθεί το πείραμα που βρίσκεται στην σελίδα 123 και ανήκει 

στην ενότητα ΦΕ1. Από το κεφάλαιο «Φως» θα πραγματοποιηθεί μέσω του παιχνιδιού, το 

πείραμα της σελίδας 143 της ενότητας ΦΕ2 και τέλος, από το κεφάλαιο «Οξέα- Βάσεις- 

Άλατα» θα υλοποιηθεί το πείραμα της σελίδας 166 που ανήκει στην ενότητα ΦΕ3. 

4.3 Αρχική σκηνή παιχνιδιού 

Η μορφή της αρχικής σκηνής του παιχνιδιού εμφανίζεται στην εικόνα 4.1. και στην εικόνα 4.2 

παρουσιάζονται τα αντικείμενα της συγκεκριμένης σκηνής και οι σχέσεις ιεραρχίας μεταξύ 

τους. Πιο αναλυτικά, η αρχική σκηνή αποτελείται από μία Main Camera η οποία 

δημιουργήθηκε από Game Object → Camera, από ένα Directional Light το οποίο 

δημιουργήθηκε από Game Object → Light → Directional Light και προσφέρει το σωστό 

φωτισμό στη σκηνή, από ένα Event System το οποίο δημιουργήθηκε από Game Object → UI 

→ Event System για την σωστή λειτουργία των κουμπιών της σκηνής και τη μετάβαση προς 

τις επόμενες σκηνές του παιχνιδιού, ένα canvas το οποίο δημιουργήθηκε από Game Object → 

UI → Canvas πάνω στο οποίο προστέθηκε ένα Panel από Game Object → UI → Panel και στη 

συνέχεια εισάχθηκε μία εικόνα η οποία χρησίμευσε ως φόντο για την αρχική σκηνή από Panel 

→ Image → Source Image και από το αναδυόμενο μενού επιλέχθηκε η εικόνα από τα αρχεία 

του υπολογιστή. Στη συνέχεια, δημιουργήθηκε ένα αντικείμενο empty από Game Object → 

Create Empty το οποίο μετονομάστηκε σε Main Menu και περιέχει συνολικά πέντε κουμπιά, 
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τέσσερα εκ των οποίων αντιστοιχούν στα κεφάλαια του βιβλίου που επιλέχθηκαν και ένα 

κουμπί που ονομάζεται «ΕΞΟΔΟΣ» από το οποίο τερματίζει η εφαρμογή. Επιπλέον το Main 

Menu περιέχει δύο text που πληροφορούν σχετικά με το περιεχόμενο της εφαρμογής και τον 

δημιουργό της. 

 

 

Εικόνα 4.1: Αρχική σκηνή παιχνιδιού 
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Εικόνα 4.2: Ιεραρχία αντικειμένων Αρχικής σκηνής 

4.4 Κείμενα παιχνιδιού 

Καθώς οι υπάρχουσες γραμματοσειρές του Unity δεν υποστηρίζουν το ελληνικό αλφάβητο, 

χρειάστηκε να εισαχθεί στο πακέτο TextMesh Pro μία συμβατή γραμματοσειρά για τη 

δημιουργία των κειμένων της αρχικής σκηνής του παιχνιδιού αλλά και για τα κείμενα των 

υπόλοιπων σκηνών. Μετά την αναζήτηση και δοκιμή διάφορων γραμματοσειρών οι οποίες 

παρουσίαζαν προβλήματα στην εμφάνιση των χαρακτήρων θ,ξ,υ κ.ά., αποφασίστηκε η χρήση 

της γραμματοσειράς «Open Sans Condensed-Light Italic SDF» η οποία υποστηρίζονταν 

πλήρως από το Unity. Αρχικά έγινε η λήψη και η αποθήκευση του αρχείο μορφής .ttf της 

γραμματοσειράς από το [16] στον υπολογιστή και στην συνέχεια για την εισαγωγή της 

γραμματοσειράς στο Unity δημιουργήθηκε ένας φάκελος με το όνομα «Fonts» στα Assets του 

project και έγινε drag and drop του αρχείου .ttf. Ωστόσο επειδή η συγκεκριμένη μορφή αρχείου 

δεν είναι αποδεκτή από το Unity έγινε μετατροπή του αρχείου σε αρχείο .asset μέσω του 

πακέτου TextMesh Pro. Τέλος, για να γίνει χρήση της συγκεκριμένης γραμματοσειράς στο 

project χρειάστηκε να δημιουργηθούν τα αντικείμενα τύπου Text - TextMeshPro στις διάφορες 

σκηνές της εφαρμογής και από το μενού Inspector στο εκάστοτε αντικείμενο στο πεδίο Font 

Asset επιλέχθηκε η συγκεκριμένη γραμματοσειρά, όπως φαίνεται στην εικόνα 4.3. 
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Εικόνα 4.3: Επιλογή Γραμματοσειράς 

4.5 Εικόνες- Κουμπιά Αρχικής σκηνής 

Στην αρχική σκηνή του παιχνιδιού όπως είδαμε παραπάνω υπάρχουν τέσσερις εικόνες οι οποίες 

αντιστοιχούν στο κάθε ένα από τα κεφάλαια του βιβλίου που επιλέχθηκαν για την εφαρμογή. 

Οι συγκεκριμένες εικόνες αποτελούν κουμπιά από τα οποία ο χρήστης μπορεί να πλοηγηθεί 

εντός των κεφαλαίων. Γι’ αυτό το λόγο μετά την εισαγωγή των εικόνων στο Unity, η οποία 

έγινε με drag and drop εντός του φακέλου images που είχε δημιουργηθεί προηγουμένως στα 

Assets του project, χρειάστηκε να γίνουν κάποιες ρυθμίσεις με σκοπό η μορφή των εικόνων να 

είναι αποδεκτή από το TextMeshPro Button. Οι ρυθμίσεις αυτές έγιναν ξεχωριστά για την κάθε 

εικόνα αλλάζοντας το Texture Type από Default σε Sprite (2D and UI), όπως φαίνεται στην 

εικόνα 4.4. 
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Εικόνα 4.4: Ρυθμίσεις εικόνων 

Τέλος, για την δημιουργία των κουμπιών με τη μορφή εικόνων, δημιουργήθηκαν στο Main 

Menu τέσσερα αντικείμενα Button – TextMeshPro και αφού έγιναν οι απαραίτητες ρυθμίσεις 

μεγέθους από το μενού Rect Transform στην καρτέλα Inspector, επιλέχθηκε από το πεδίο 

Source Images του μενού Image η εκάστοτε εικόνα (εικόνα 4.5). 



Κεφάλαιο 4 

38 

 

Εικόνα 4.5: Δημιουργία κουμπιών με μορφή εικόνων 

 

4.6 Script Αρχικής σκηνής 

Η αρχική σκήνη της εφαρμογής περιέχει πέντε κουμπιά. Τα τέσσερα από αυτά αντιστοιχούν, 

όπως είδαμε στην προηγούμενη ενότητα, στα τέσσερα κεφάλαια του βιβλίου για τα οποία 

υλοποιούνται πειράματα εντός της εφαρμογής. Τέλος, το πέμπτο κουμπί είναι το κουμπί 

ΕΞΟΔΟΣ το οποίο τερματίζει την εφαρμογή. Για να λειτουργήσουν τα συγκεκριμένα 

αντικείμενα ως κουμπιά χρειάζεται η δημιουργία ενός script. Αυτό πραγματοποιήθηκε 

επιλέγοντας το Main Menu και στη συνέχεια από το Inspector, επιλέγοντας Add Component 

και συμπληρώνοντας στο μενού αναζήτησης που εμφανίζεται την ονομασία που θέλουμε να 

δώσουμε στο script, στην συγκεκριμένη περίπτωση δόθηκε το όνομα Mainmenu, και πατώντας 

New script → Create and Add. Μετά το πέρας της δημιουργίας του script και κάνοντας δεξί 

κλικ πάνω σε αυτό επιλέγουμε Edit Script και με αυτό τον τρόπο ανοίγει το script μέσω του 

Microsoft Visual Studio και μπορεί να αρχίσει η συγγραφή αυτού. Βασικό κομμάτι της 

συγγραφής ενός script που επιτρέπει την εναλλαγή μεταξύ διάφορων σκηνών είναι η εισαγωγή 

σε αυτό των βιβλιοθηκών UnityEngine και UnityEngine.SceneManagement όπως φαίνεται στις 

γραμμές 3 και 4 στην εικόνα 4.6. Επιπλέον, το script Mainmenu, όπως επίσης φαίνεται στην 
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εικόνα 4.6, αποτελείται από πέντε μεθόδους τύπου void [THERMOTITA(), 

HLEKTROMAGNITISMOS(), FWS(), OBA(), QuitGame()]. Οι τέσσερις πρώτες μέθοδοι 

χρησιμοποιούν δυναμικό τρόπο για την εναλλαγή των σκηνών ανάλογα με το κουμπί που θα 

επιλέξει ο χρήστης ενώ η πέμπτη μέθοδος χρησιμοποιεί την εντολή Application.Quit(); για να 

τερματίσει την εφαρμογή (Εικόνα 4.6).   

 

 

Εικόνα 4.6: Script Αρχικής Σκηνής 

 

 

Τέλος, για να γίνει η απαραίτητη αντιστοιχία της εκάστοτε μεθόδου με ένα συγκεκριμένο 

κουμπί, είναι απαραίτητο να επιλεχθεί από το πεδίο Button που εμφανίζεται στο Inspector του 

κάθε κουμπιού On Click ()→ + και στη συνέχεια drag and drop το αντικείμενο Main menu στο 

πεδίο που έχει δημιουργηθεί και αλλάζοντας την επιλογή No Function με την εκάστοτε μέθοδο 

(Εικόνα 4.7). 
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Εικόνα 4.7: Αντιστοιχία κουμπιού με μέθοδο 

4.7 Ο βασικός χαρακτήρας του παιχνιδιού 

Ο Robi αποτελεί τον βασικό χαρακτήρα του παιχνιδιού και έχει την ιδιότητα του “Player”. Η 

μορφή του φαίνεται στην εικόνα 4.8. Σκοπός του είναι να περισυλλέξει με την καθοδήγηση του 

χρήστη όλα τα αντικείμενα που υπάρχουν στην μπάρα των υλικών και είναι απαραίτητα για 

την υλοποίηση του πειράματος.   

 

Εικόνα 4.8: Robi -Ο βασικός χαρακτήρας του παιχνιδιού 
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Ο Rodi προστέθηκε στις σκηνές paixnidi_1,paixnidi_2,paixnidi_3  καθώς και στην σκηνή 

paixnidi_4 με drag and drop από τον φάκελο Αssets του project. Επίσης, για την σωστή 

λειτουργία της κίνησης του έγιναν οι ρυθμίσεις που φαίνονται στην εικόνα 4.9. Αρχικά, 

προστέθηκε ένα Rigibody (Robi → Add Component → Rigibody) και στην συνέχεια από το 

πεδίο Constraints το οποίο βρίσκετε στο Rigibody του Inspector του Robi επιλέχτηκαν από το 

πεδίο Freeze position Y καθώς και από το πεδίο Freeze Rotation X,Y,Z. Επίσης, στο πεδίο 

Inspector του Robi  με την διαδικασία Add Component → Box Collider προστέθηκε ένα 

Collider σε σχήμα κύβου γύρω από τον χαρακτήρα. 

 

Εικόνα 4.9: Βασικές ρυθμίσεις Robi 

To script που είναι υπεύθυνο για την κίνηση του Robi απεικονίζεται στην εικόνα 4.10 και 

εισήχθει στο Inspector του χαρακτήρα από Add Component → Controler (Script). Τέλος, για 

τον χειρισμό του Robi από τον χρήστη προστέθηκε το έτοιμο πακέτο Joystick Pack από το 

Asset store της Unity → Search για Joystick Pack → Import.  
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Εικόνα 4.10: Script “Controler” 

4.8 Ρυθμίσεις ήχου 

Για την εισαγωγή ήχων στο project χρειάστηκε αρχικά η δημιουργία ενός φακέλου στα Assets 

του project με την ονομασία Audio. Μέσα σε αυτό τον φάκελο αποθηκεύτηκαν οι ήχοι που θα 

χρησιμοποιηθούν στην εφαρμογή σε μορφή mp3. Τα αρχεία ήχων του παιχνιδιού είναι δύο, ο 

ήχος extra που θα χρησιμοποιηθεί για τη σωστή επιλογή υλικών από τον χρήστη και ο ήχος 

wrong_answer που θα χρησιμοποιηθεί αντίστοιχα για την λανθασμένη επιλογή υλικών. Οι 

ρυθμίσεις για την χρήση και την ενεργοποίηση των ήχων εντός του παιχνιδιού θα αναλυθεί στα 

επόμενα κεφάλαια. 

4.9 Επίλογος 

Σε αυτό το σημείο έχει ολοκληρωθεί η δημιουργία της αρχικής σκηνής του παιχνιδιού και έχουν 

εισαχθεί στο project ο βασικός χαρακτήρας και οι ήχοι που θα χρησιμοποιηθούν στη συνέχεια 

για την δημιουργία των παιχνιδιών. 
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Κεφάλαιο 5ο: Εφαρμογή πειράματος για το κεφάλαιο Θερμότητα 

5.1 Εισαγωγή 

Στον παρόν κεφάλαιο γίνεται η ανάλυση των μαθησιακών στόχων του πειράματος που 

επιλέχθηκε προς εφαρμογή από το κεφάλαιο ΘΕΡΜΟΤΗΤΑ του βιβλίου Φυσικά Δημοτικού – 

Ερευνώ και Ανακαλύπτω της ΣΤ’ τάξης. Επιπλέον παρουσιάζονται αναλυτικά όλα τα βήματα 

που ακολουθήθηκαν για την δημιουργία των σκηνών του κεφαλαίου και την υλοποίηση του 

πειράματος με χρήση επαυξημένης πραγματικότητας. 

5.2 Πείραμα ενότητα ΦΕ1: Η ΘΕΡΜΟΤΗΤΑ ΜΕΤΑΔΙΔΕΤΑΙ ΜΕ ΑΓΩΓΗ 

Η ενότητα ΦΕ1:Η ΘΕΡΜΟΤΗΤΑ ΜΕΤΑΔΙΔΕΤΑΙ ΜΕ ΑΓΩΓΗ ανήκει στο κεφάλαιο 

ΘΕΡΜΟΤΗΤΑ και το πείραμα που την συνοδεύει στο Τετράδιο εργασιών στη σελίδα 52 είναι 

το πείραμα που επιλέχθηκε προς υλοποίηση μέσω της εφαρμογής επαυξημένης 

πραγματικότητας. Ο κύριος στόχος του κεφαλαίου είναι να μελετήσουν και να κατανοήσουν 

οι μαθητές τους τρόπους μετάδοσης, μεταφοράς και διάδοσης της θερμότητας. Πιο 

συγκεκριμένα, το πείραμα της σελίδας 52 εστιάζει στη μετάδοση της θερμότητας με αγωγή, 

δηλαδή στη μετάδοση μέσα από ένα υλικό σώμα, και στην κατανόηση από τους μαθητές της 

ταξινόμησης των υλικών σε καλούς και κακούς αγωγούς της θερμότητας. Τα υλικά τα οποία 

απαιτούνται για την υλοποίηση του πειράματος είναι μία μεταλλική βελόνα πλεξίματος, ένας 

φελλός και ένα κερί. Η εκφώνηση του πειράματος ζητάει από τους μαθητές να στερεώσουν 

αρχικά το φελλό στη μία άκρη της βελόνας πλεξίματος και στη συνέχεια να στάξουν επάνω 

στη βελόνα μερικές σταγόνες κερί. Τέλος, τους προτρέπει να δουν το αποτέλεσμα που θα 

προκύψει εάν θερμάνουν τη άλλη άκρη της βελόνας με την φλόγα του κεριού. Σε αυτό το 

σημείο οι μαθητές θα παρατηρήσουν πως οι στερεές σταγόνες κεριού πάνω στη βελόνα 

αρχίζουν να λιώνουν και να πέφτουν, μάλιστα πρώτες πέφτουν εκείνες οι σταγόνες οι οποίες 

βρίσκονται πιο κοντά στην πηγή θερμότητας, δηλαδή στο κερί. Εκ του αποτελέσματος, οι 

μαθητές θα είναι σε θέση να συμπεραίνουν ότι η θερμότητα μεταδίδεται μέσα από την 

μεταλλική βελόνα πλεξίματος με αγωγή και από το πιο θερμό προς στο πιο ψυχρό της άκρο. Η 

εφαρμογή PhysicX-R υλοποιεί όλα τα παραπάνω με χρήση επαυξημένης πραγματικότητας 

μέσω ενός QRcode που έχει προστεθεί στην σελίδα 52 του Τετραδίου εργασιών. 

5.3 Οι σκηνές του πειράματος – ΘΕΡΜΟΤΗΤΑ 

Στην εικόνα 5.1 απεικονίζονται οι συνολικά πέντε σκηνές από τις οποίες αποτελείται το 

πείραμα του κεφαλαίου ΘΕΡΜΟΤΗΤΑ στην εφαρμογή, καθώς και η σειρά με την οποία 

εμφανίζονται. Αρχικά, ο χρήστης, αφού επιλέξει το κεφάλαιο ΘΕΡΜΟΤΗΤΑ από το 

αντίστοιχο κουμπί στην αρχική σκήνη, μεταβαίνει στη σκηνή epilogh_1 στην οποία 

εμφανίζονται όλα τα διαθέσιμα πειράματα από τις διάφορες ενότητες του κεφαλαίου. Στην 

συνέχεια, πατώντας το κουμπί Ας παίξουμε επιλέγει το πείραμα το οποίο θέλει να υλοποιήσει 

και περνάει στην σκηνή paixnidi_1 όπου ενεργοποιείται αυτόματα η κάμερα της συσκευής και 

σκανάροντας το QRcode που βρίσκεται στην σελίδα του συγκεκριμένου πειράματος στο 

Τετράδιο εργασιών, εμφανίζεται μπροστά του ένας λαβύρινθος με χρήση επαυξημένης 
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πραγματικότητας και από πάνω μία μπάρα με τα αντικείμενα που πρέπει να συλλέξει. Αφού 

ολοκληρωθεί η συλλογή όλων των αντικειμένων και βγει ο χρήστης από τον λαβύρινθο 

μεταβαίνει αυτόματα στην σκηνή perigrafh_peiramatos_1 όπου εμφανίζονται οι οδηγίες για 

την υλοποίηση του πειράματος που θα ακολουθήσει. Στην συνέχεια πατώντας το κουμπί Ας 

μάθουμε μεταβαίνει στη σκηνή peirama_1 οπού ενεργοποιείται αυτόματα η κάμερα και 

σκανάροντας ξανά το QRcode εμφανίζεται μπροστά στον χρήστη ένα τραπέζι, με χρήση 

επαυξημένης πραγματικότητας, πάνω στο οποίο υλοποιείται το πείραμα. Τέλος, 

ολοκληρώνοντας μία-μία τις φάσεις του πειράματος από το πάνω μέρος της οθόνης ο χρήστης 

μπορεί να επιλέξει το κουμπί ΣΥΜΠΕΡΑΣΜΑ από το οποίο μεταβαίνει στην τελική σκηνή του 

πειράματος, την σκηνή sumperasma_1, όπου εμφανίζονται συμπληρωμένα η παρατήρηση και 

το συμπέρασμα που ζητούνται από το βιβλίο.  

 

Εικόνα 5.1: Σκηνές πειράματος - ΘΕΡΜΟΤΗΤΑ 
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5.3.1 Η σκηνή epilogh_1 

Η σκηνή epilogh_1 (Εικόνα 5.2) είναι, όπως είδαμε προηγουμένως, η πρώτη σκηνή στην οποία 

μεταβαίνει ο χρήστης μόλις επιλέξει το κουμπί που αντιστοιχεί στο κεφάλαιο ΘΕΡΜΟΤΗΤΑ 

από την Αρχική σκηνή. Η δημιουργία των αντικειμένων της συγκεκριμένης σκηνής έγινε με 

παρόμοιο τρόπο όπως αυτή των αντικειμένων της Αρχικής σκηνής. Η σκηνή αποτελείται από 

μία Main Camera (Game Object → Camera), ένα Directional Light (Game Object → Light → 

Directional Light), ένα Event System (Game Object → UI → Event System) και ενός Canvas 

(Game Object → UI → Canvas). Τέλος, πάνω στο Canvas δημιουργήθηκε ένα αντικείμενο 

Panel (Game Object → UI → Panel), στο οποίο εισάχθηκε το φόντο της σκηνής από Panel → 

Image → Source Image, και ένα αντικείμενο Empty (Game Object → Create Empty) το οποίο 

μετονομάστηκε σε PERILIPSIMENU και περιέχει συνολικά τέσσερα αντικείμενα Text-

TextMeshPro (Game Object → UI → Text-TextMeshPro) και δύο αντικείμενα Button-

TextMeshPro (Game Object → UI → Button-TextMeshPro). Το script [PERILIPSIMENU → 

Inspector → Add Component → Perilipsi (Script)] που χρησιμοποιήθηκε για την λειτουργία 

των δύο αυτών κουμπιών, είναι παρόμοιο με αυτό της Αρχικής σκηνής, το οποίο 

παρουσιάστηκε αναλυτικά στην υποενότητα 4.6 και περιέχει τις μεθόδους PLAY() και 

BACK(). 

 

Εικόνα 5.2: Η σκηνή epilogh_1 
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5.3.2 Η σκηνή paixnidi_1 

Πατώντας το κουμπί Ας παίξουμε από την σκηνή epilogh_1 ο χρήστης μεταβαίνει στη σκηνή 

paixnidi_1, όπου ενεργοποιείται η κάμερα του και διαβάζοντας το αντίστοιχο QRcode 

εμφανίζεται μπροστά του ένας λαβύρινθος επαυξημένης πραγματικότητας. Η ιεραρχία των 

αντικειμένων της σκηνής paixnidi_1 φαίνεται στην εικόνα 5.3. 

 

Εικόνα 5.3: Ιεραρχία αντικειμένων σκηνής paixnidi_1 

 

Η συγκεκριμένη σκηνή αποτελείται από ένα Direction Light (Game Object → Light → 

Directional Light), από μία ARCamera (Game Object → Vuforia Engine → AR Camera), από 

ένα AR Session (Game Object → XR → AR Session) απαραίτητο για την σωστή λειτουργία 

όλων των AR στοιχείων, από ένα Canvas (Game Object → UI → Canvas), το οποίο περιέχει 
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τρία αντικείμενα Text – TextMeshPro (Game Object → UI → Text – TextMeshPro) που 

απαρτίζουν την μπάρα με τα υλικά που πρέπει να συλλέξει ο χρήστης από τον λαβύρινθο για 

την υλοποίηση του πειράματος και  το αντικείμενο Fixed Joystick που εισάχθηκε με drag and 

drop από τον φάκελο Joystick pack στα Assets του project. Τέλος η σκηνή paixnidi_1 περιέχει 

και το αντικείμενο Image Target (Game Object → Vuforia Engine → Image), από το Inspector 

του οποίου στο πεδίο Image Target Behavior (Script) επιλέγουμε στο Database την βάση 

δεδομένων ptuxiakh_database, που δημιουργήσαμε προηγουμένως, και στο Image Target 

επιλέγουμε το ar_marker3 που αντιστοιχεί στο κεφάλαιο ΘΕΡΜΟΤΗΤΑ. Με αυτές τις 

ρυθμίσεις όταν η κάμερα του χρήστη θα διαβάζει το συγκεκριμένο QRcode θα εμφανίζονται 

στην οθόνη του όλα τα αντικείμενα τα οποία δημιουργήθηκαν στη συνέχεια εντός του 

αντικειμένου Image Target.  

Πιο αναλυτικά, τα αντικείμενα αυτά είναι ένα Plane (Game Object → 3D Object → Plane), το 

οποίο περιέχει την εικόνα που επιλέχθηκε ως δάπεδο για τον συγκεκριμένο λαβύρινθο, έντεκα 

αντικείμενα Cube (Game Object → 3D Object → Cube), με τα οποία σχεδιάστηκαν οι τοίχοι 

του λαβύρινθου και από το Inspector του καθενός έγιναν οι ρυθμίσεις Add Component → Box 

Collider με σκοπό να αποκτήσουν υπόσταση, πέντε έτοιμα μοντέλα αντικειμένων τα οποία 

φαίνονται στην εικόνα 5.4 και εισάχθηκαν με drag and drop από τον φάκελο models ο οποίος 

είχε δημιουργηθεί προηγουμένως στα Assets του project, ο Robi που είναι ο βασικός 

χαρακτήρας του παιχνιδιού και εισάχθηκε επίσης με drag and drop από τον ίδιο φάκελο, πέντε 

αντικείμενα Audio Source (Game Object → Audio → Audio Source) και πέντε αντικείμενα 

Event System (Game Object → UI → Event System).   

 

Εικόνα 5.4: Υλικά παιχνιδιού για το κεφάλαιο ΘΕΡΜΟΤΗΤΑ 

 

Τα πέντε αντικείμενα Audio Source, τρία με τον ήχο extra και δύο με τον ήχο wrong_answer, 

τοποθετήθηκαν πάνω στα πέντε υλικά που υπάρχουν εντός του λαβυρίνθου με σκοπό να 

ειδοποιούν τον χρήστη για τη σωστή ή λανθασμένη επιλογή υλικών. Η ενεργοποίηση των ήχων 
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αυτών γίνεται με την βοήθεια των πέντε αντικειμένων Event System, τα οποία έχουν επίσης 

τοποθετηθεί πάνω στα πέντε υλικά εντός του λαβυρίνθου και φέρουν αντίστοιχη ονομασία 

(EventCandle, Eventcork, EventRing, Eventcandlestick, EventNeedle_End). Επιπλέον, τα 

πέντε αντικείμενα Event System είναι υπεύθυνα και για την εξαφάνιση των υλικών του 

πειράματος, τόσο από τον λαβύρινθο όσο και από την μπάρα, όταν ο χρήστης τα περισυλλέξει 

με την βοήθεια του Robi. Με βάση τα παραπάνω υπάρχουν τριών ειδών ρυθμίσεις για τα 

αντικείμενα Event System.  

Οι ρυθμίσεις για τα Event System που αντιστοιχούν στα αντικείμενα που δεν πρέπει να 

συλλέξει ο χρήστης (Δαχτυλίδι, Κηροπήγιο) είναι Inspector → Add Component → Box 

Collider → ενεργοποίηση του πεδίου Is Trigger και Inspector → Add Component → 

Sound_event (Script) και drag and drop το αντίστοιχο αντικείμενο ήχου. Το script που αφορά 

τις συγκεκριμένες ρυθμίσεις φαίνεται στην εικόνα 5.5. 

 

Εικόνα 5.5: Script “Sound_event” 

Οι ρυθμίσεις για τα Event System που πρέπει να συλλέξει ο χρήστης για την υλοποίηση του 

πειράματος (Κερί, Φελλός) είναι Inspector → Add Component → Box Collider → 

ενεργοποίηση του πεδίου Is Trigger και Inspector → Add Component → Trigger_item και στην 

συνέχεια drag and drop το εκάστοτε μοντέλο αντικειμένου, Text – TextMeshPro και το 

αντίστοιχο αντικείμενο ήχου.  Το script που αφορά τις συγκεκριμένες ρυθμίσεις φαίνεται στην 

εικόνα 5.6. 
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Εικόνα 5.6: Script “Trigger_item” 

Οι τελευταίες ρυθμίσεις για τα Event System αφορούν το τελευταίο υλικό εντός του 

λαβυρίνθου (Βελόνα), το οποίο εκτός του ρόλου του ως υλικό έχει και την ιδιότητα αλλαγής 

σκηνής. Οι ρυθμίσεις που πρέπει να γίνουν είναι Inspector → Add Component → Box Collider 

→ ενεργοποίηση του πεδίου Is Trigger και Inspector → Add Component → Trigger_item_end 

και στην συνέχεια drag and drop το εκάστοτε μοντέλο αντικειμένου, Text – TextMeshPro και 

το αντίστοιχο αντικείμενο ήχου. Το script που αφορά τις συγκεκριμένες ρυθμίσεις φαίνεται 

στην εικόνα 5.7. 

 

Εικόνα 5.7: Script “Trigger_item_end” 
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Η τελική εμφάνιση της σκηνής paixnidi_1 μετά τη δημιουργία και τις ρυθμίσεις όλων των 

αντικειμένων που αναλύσαμε παραπάνω παρουσιάζεται στην εικόνα 5.8. 

 

Εικόνα 5.8: Τελική εμφάνιση σκηνής paixnidi_1 

5.3.3 Η σκηνή perigrafh_peiramatos_1 

Η σκηνή perigrafh_peiramatos_1 (Εικόνα 5.9) είναι η σκηνή στην οποία μεταβαίνει ο χρήστης 

μόλις ολοκληρώσει το παιχνίδι του λαβυρίνθου που δημιουργήθηκε για το κεφάλαιο 

ΘΕΡΜΟΤΗΤΑ. Η συγκεκριμένη σκηνή αποτελείται από μία Main Camera (Game Object → 

Camera), ένα Directional Light (Game Object → Light → Directional Light), ένα Event System 

(Game Object → UI → Event System) και ενός Canvas (Game Object → UI → Canvas). Τέλος, 

πάνω στο Canvas δημιουργήθηκε ένα αντικείμενο Panel (Game Object → UI → Panel), στο 

οποίο εισάχθηκε το φόντο της σκηνής από Panel → Image → Source Image, και ένα 

αντικείμενο Empty (Game Object → Create Empty) το οποίο μετονομάστηκε σε 

PERILIPSIMENU και περιέχει συνολικά πέντε αντικείμενα Text-TextMeshPro (Game Object 

→ UI → Text-TextMeshPro) και δύο αντικείμενα Button-TextMeshPro (Game Object → UI 

→ Button-TextMeshPro). Το script [PERILIPSIMENU → Inspector → Add Component → 

Perilipsi (Script)] που χρησιμοποιήθηκε για την λειτουργία των δύο αυτών κουμπιών, είναι 

παρόμοιο με αυτό της Αρχικής σκηνής, το οποίο παρουσιάστηκε αναλυτικά στην υποενότητα 

4.6 και περιέχει τις μεθόδους PLAY() και BACK(). 



Εφαρμογή πειράματος για το κεφάλαιο Θερμότητα 

51 

 

Εικόνα 5.9: Η σκηνή perigrafh_peiramatos_1 

 

5.3.4 Η σκηνή peirama_1 

Η σκηνή peirama_1 είναι η σκηνή στην οποία υλοποιείται το πείραμα του κεφαλαίου 

ΘΕΡΜΟΤΗΤΑ με χρήση επαυξημένης πραγματικότητας. Όπως φαίνεται και στην εικόνα 5.10 

η συγκεκριμένη σκηνή αποτελείται από ένα Direction Light (Game Object → Light → 

Directional Light), από μία ARCamera (Game Object → Vuforia Engine → AR Camera), από 

ένα AR Session (Game Object → XR → AR Session), ένα Event System (Game Object → UI 

→ Event System) και από ένα Image Target (Game Object → Vuforia Engine → Image). Στην 

συνέχεια, από το Inspector του Image Target επιλέχθηκε στο Database στο πεδίο Image Target 

Behavior (Script) η βάση δεδομένων ptuxiakh_database και στο Image Target επιλέχθηκε το 

ar_marker3 που αντιστοιχεί στο κεφάλαιο ΘΕΡΜΟΤΗΤΑ. Επιπλέον, στο αντικείμενο Image 

Target προστέθηκαν με drag and drop από τον φάκελο models που βρίσκεται στα Assets του 

project, τα μοντέλα αντικειμένων Table_Large_Rectangular_01 και Candle, δυο φορές 

ανάλογα με τη θέση τους στο χώρο τα μοντέλα αντικειμένων needle και Cork και τέλος το 

αντικείμενο drop έξι φορές σε έξι διαφορετικές θέσεις στο χώρο. Η εμφάνιση ή η απόκρυψη 

των συγκεκριμένων αντικειμένων γίνεται με βάση το κουμπί που θα επιλέξει ο χρήστης κατά 
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την υλοποίηση του πειράματος. Πιο συγκεκριμένα υπάρχουν πέντε κουμπιά στην 

συγκεκριμένη σκηνή τα οποία δημιουργήθηκαν από Game Object → UI → Button- 

TextMeshPro εντός του αντικειμένου Canvas που δημιουργήθηκε πάνω στην ARCamera από 

Game Object → UI → Canvas.  

 

 

Εικόνα 5.10: Ιεραρχία αντικειμένων σκηνής peirama_1 

 

Το script το οποίο επιτρέπει τη εναλλαγή μεταξύ των φάσεων του πειράματος σύμφωνα πάντα 

με τις κινήσεις του χρήστη βρίσκεται στο ΠΑΡΑΡΤΗΜΑ Α και για την εισαγωγή του έγιναν 

οι κινήσεις ARCamera → Inspector → Add Component → Thesh (Script) και στην συνέχεια 

με drag and drop έγινε η αντιστοιχία των αντικειμένων της σκηνής ως ορίσματα στο script. Οι 

φάσεις υλοποίησης του πειράματος φαίνονται στην εικόνα 5.11. 
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Εικόνα 5.11: Υλοποίηση πειράματος - ΘΕΡΜΟΤΗΤΑ 

5.3.5 Η σκηνή sumperasma_1 

Η σκηνή sumperasma_1 (Εικόνα 5.12) είναι η τελική σκηνή που δημιουργήθηκε για το 

κεφάλαιο ΘΕΡΜΟΤΗΤΑ και περιέχει την παρατήρηση και το συμπέρασμα του πειράματος 

που υλοποιήθηκε στην προηγούμενη σκηνή. Η συγκεκριμένη σκηνή αποτελείται από μία Main 

Camera (Game Object → Camera), ένα Directional Light (Game Object → Light → Directional 

Light), ένα Event System (Game Object → UI → Event System) και ενός Canvas (Game Object 

→ UI → Canvas). Τέλος, πάνω στο Canvas δημιουργήθηκε ένα αντικείμενο Panel (Game 

Object → UI → Panel), στο οποίο εισάχθηκε το φόντο της σκηνής από Panel → Image → 

Source Image, και ένα αντικείμενο Empty (Game Object → Create Empty) το οποίο 

μετονομάστηκε σε PERILIPSIMENU και περιέχει συνολικά έξι αντικείμενα Text-

TextMeshPro (Game Object → UI → Text-TextMeshPro) και ένα αντικείμενο Button-
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TextMeshPro (Game Object → UI → Button-TextMeshPro). Το script [PERILIPSIMENU → 

Inspector → Add Component → Perilipsi (Script)] που χρησιμοποιήθηκε για την λειτουργία 

του κουμπιού, είναι παρόμοιο με αυτό της Αρχικής σκηνής, το οποίο παρουσιάστηκε 

αναλυτικά στην υποενότητα 4.6 και περιέχει μόνο την μέθοδο BACK().  

 

Εικόνα 5.12: Η σκηνή sumperasma_1 

 

5.4 Επίλογος 

Με τις παραπάνω πέντε σκηνές ολοκληρώνεται η υλοποίηση του πειράματος για το κεφάλαιο 

ΘΕΡΜΟΤΗΤΑ. Με την ολοκλήρωση του πειράματος θα πρέπει να έχουν επιτευχθεί οι 

μαθησιακοί στόχοι που τέθηκαν στην αρχή του κεφαλαίου. 
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Κεφάλαιο 6ο: Εφαρμογή πειράματος για το κεφάλαιο 

Ηλεκτρομαγνητισμός 

6.1 Εισαγωγή 

Στο κεφάλαιο αυτό, μετά την ανάλυση των μαθησιακών στόχων του Κεφαλαίου 

ΗΛΕΚΤΡΟΜΑΓΝΗΤΙΣΜΟΣ του βιβλίου Φυσικά Δημοτικού – Ερευνώ και Ανακαλύπτω της 

ΣΤ’ τάξης καθώς και του πειράματος που επιλέχθηκε για υλοποίηση μέσω της εφαρμογής, 

γίνεται μία αναλυτική παρουσίαση της διαδικασίας δημιουργίας  όλων των σκηνών για την 

εφαρμογή του συγκεκριμένου πειράματος με χρήση επαυξημένης πραγματικότητας. 

6.2 Πείραμα ενότητα ΦΕ1: Ο ΜΑΓΝΗΤΗΣ 

Η ενότητα ΦΕ1:Ο ΜΑΓΝΗΤΗΣ είναι η πρώτη ενότητα του κεφαλαίου 

ΗΛΕΚΤΡΟΜΑΓΝΗΤΙΣΜΟΣ του βιβλίου Φυσικά Δημοτικού – Ερευνώ και Ανακαλύπτω της 

ΣΤ’ τάξης και το πείραμα που επιλέχθηκε προς υλοποίηση μέσω της εφαρμογής επαυξημένης 

πραγματικότητας βρίσκεται στη σελίδα 123 του Τετραδίου εργασιών. Ο κύριος στόχος του 

κεφαλαίου είναι να έρθουν οι μαθητές σε επαφή και να κατανοήσουν τα ηλεκτρομαγνητικά 

φαινόμενα, τα χαρακτηριστικά τους αλλά και τις εφαρμογές τους. Πιο συγκεκριμένα, το 

πείραμα της σελίδας 123 εστιάζει στην ελκτική δύναμη των μαγνητών και στην κατανόηση 

από τους μαθητές της ταξινόμησης των υλικών σε σιδηρομαγνητικά ή όχι, δηλαδή στα υλικά 

που έλκονται ή όχι από τον μαγνήτη. Για την υλοποίηση του πειράματος ζητείται η 

συγκέντρωση διάφορων αντικειμένων από διαφορετικά υλικά και η ύπαρξη ενός μαγνήτη. Στη 

συνέχεια, η εκφώνηση του πειράματος ζητάει από τους μαθητές να πλησιάσουν τον μαγνήτη 

στα διάφορα αντικείμενα που έχουν συλλέξει και να σημειώσουν ποια αντικείμενα έλκονται 

και ποια όχι και από τι υλικό είναι φτιαγμένα. Σε αυτό το σημείο οι μαθητές θα παρατηρήσουν 

πως τα αντικείμενα που είναι φτιαγμένα από μέταλλο τείνουν να αντιδρούν στην ελκτική 

δύναμη που τους ασκεί ο μαγνήτης σε αντίθεση με άλλα αντικείμενα φτιαγμένα από γυαλί ή 

ξύλο. Η εφαρμογή PhysicX-R υλοποιεί όλα τα παραπάνω με χρήση επαυξημένης 

πραγματικότητας μέσω ενός QRcode που έχει προστεθεί στην σελίδα 123 του Τετραδίου 

εργασιών. 

6.3 Οι σκηνές του πειράματος – ΗΛΕΚΤΡΟΜΑΓΝΗΤΙΣΜΟΣ 

Η εικόνα 6.1 απεικονίζει τις συνολικά πέντε σκηνές από τις οποίες αποτελείται το πείραμα του 

κεφαλαίου ΗΛΕΚΤΡΟΜΑΓΝΗΤΙΣΜΟΣ, αλλά και την σειρά με την οποία εμφανίζονται εντός 

της εφαρμογής. Αρχικά, ο χρήστης, αφού επιλέξει το κουμπί που αντιστοιχεί στο κεφάλαιο 

ΗΛΕΚΤΡΟΜΑΓΝΗΤΙΣΜΟΣ από την αρχική σκήνη, μεταβαίνει στη σκηνή epilogh_2 στην 

οποία εμφανίζονται όλα τα διαθέσιμα πειράματα από τις διάφορες ενότητες του κεφαλαίου. 

Στην συνέχεια, πατώντας το κουμπί Ας παίξουμε επιλέγει το πείραμα το οποίο θέλει να 

υλοποιήσει και περνάει στην σκηνή paixnidi_2 όπου ενεργοποιείται αυτόματα η κάμερα της 

συσκευής και σκανάροντας το QRcode που βρίσκεται στην σελίδα 123 στο Τετράδιο εργασιών, 

εμφανίζεται μπροστά του ένας λαβύρινθος με χρήση επαυξημένης πραγματικότητας και από 

πάνω μία μπάρα με τα αντικείμενα που πρέπει να συλλέξει. Αφού ολοκληρωθεί η συλλογή 
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όλων των αντικειμένων και βγει ο χρήστης από τον λαβύρινθο μεταβαίνει αυτόματα στην 

σκηνή perigrafh_peiramatos_2 όπου εμφανίζονται οι οδηγίες για την υλοποίηση του 

πειράματος που θα ακολουθήσει. Στην συνέχεια πατώντας το κουμπί Ας μάθουμε μεταβαίνει 

στη σκηνή peirama_2 οπού ενεργοποιείται ξανά η κάμερα του με αυτόματο τρόπο και 

διαβάζοντας το QRcode  της σελίδας 123 εμφανίζεται μπροστά στον χρήστη ένα τραπέζι, με 

χρήση επαυξημένης πραγματικότητας, πάνω στο οποίο υλοποιείται το πείραμα. Σε αυτό το 

σημείο ο χρήστης πατώντας ένα- ένα τα κουμπιά που αντιστοιχούν στα διάφορα αντικείμενα 

από το πάνω μέρος της οθόνης παρατηρεί ποια έλκονται και ποια όχι και στη συνέχεια 

πατώντας το κουμπί ΣΥΜΠΕΡΑΣΜΑ μεταβαίνει στην τελική σκηνή του πειράματος, την σκηνή 

sumperasma_2, όπου εμφανίζονται συμπληρωμένα η παρατήρηση και το συμπέρασμα του 

πειράματος.  

 

Εικόνα 6.1: Σκηνές πειράματος - ΗΛΕΚΤΡΟΜΑΓΝΗΤΙΣΜΟΣ 
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6.3.1 Η σκηνή epilogh_2 

Η σκηνή epilogh_2 (Εικόνα 6.2) αποτελεί την πρώτη σκηνή στην οποία μεταβαίνει ο χρήστης 

μόλις επιλέξει το κουμπί που αντιστοιχεί στο κεφάλαιο ΗΛΕΚΤΡΟΜΑΓΝΗΤΙΣΜΟΣ από την 

Αρχική σκηνή. Η δημιουργία των αντικειμένων της συγκεκριμένης σκηνής έγινε με παρόμοιο 

τρόπο όπως αυτή των αντικειμένων της Αρχικής σκηνής και της σκηνής epilogh_1. Έτσι, η 

σκηνή αποτελείται από μία Main Camera (Game Object → Camera), ένα Directional Light 

(Game Object → Light → Directional Light), ένα Event System (Game Object → UI → Event 

System) και ενός Canvas (Game Object → UI → Canvas). Τέλος, πάνω στο Canvas 

δημιουργήθηκε ένα αντικείμενο Panel (Game Object → UI → Panel), στο οποίο εισάχθηκε το 

φόντο της σκηνής από Panel → Image → Source Image, και ένα αντικείμενο Empty (Game 

Object → Create Empty) το οποίο μετονομάστηκε σε PERILIPSIMENU και περιέχει συνολικά 

πέντε αντικείμενα Text-TextMeshPro (Game Object → UI → Text-TextMeshPro) και δύο 

αντικείμενα Button-TextMeshPro (Game Object → UI → Button-TextMeshPro). Το script 

[PERILIPSIMENU → Inspector → Add Component → Perilipsi_2 (Script)] που 

χρησιμοποιήθηκε για την λειτουργία των δύο αυτών κουμπιών, είναι παρόμοιο με αυτό της 

Αρχικής σκηνής, το οποίο παρουσιάστηκε αναλυτικά στην υποενότητα 4.6 και περιέχει τις 

μεθόδους PLAY() και BACK(). 

 

Εικόνα 6.2: Η σκηνή epilogh_2 
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6.3.2 Η σκηνή paixnidi_2 

Πατώντας το κουμπί Ας παίξουμε από την σκηνή epilogh_2 ο χρήστης μεταβαίνει στη σκηνή 

paixnidi_2, όπου ενεργοποιείται η κάμερα του και διαβάζοντας το αντίστοιχο QRcode 

εμφανίζεται μπροστά του ένας λαβύρινθος επαυξημένης πραγματικότητας. Η ιεραρχία των 

αντικειμένων της σκηνής paixnidi_2 φαίνεται στην εικόνα 6.3. 

 

Εικόνα 6.3: Ιεραρχία αντικειμένων σκηνής paixnidi_2 
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Όπως φαίνεται από την εικόνα η συγκεκριμένη σκηνή αποτελείται από ένα Direction Light 

(Game Object → Light → Directional Light), από μία ARCamera (Game Object → Vuforia 

Engine → AR Camera), από ένα AR Session (Game Object → XR → AR Session), από ένα 

Canvas (Game Object → UI → Canvas), το οποίο περιέχει έξι αντικείμενα Text – TextMeshPro 

(Game Object → UI → Text – TextMeshPro) που απαρτίζουν την μπάρα με τα υλικά που 

πρέπει να συλλέξει ο χρήστης από τον λαβύρινθο για την υλοποίηση του πειράματος και  το 

αντικείμενο Fixed Joystick που εισάχθηκε με drag and drop από τον φάκελο Joystick pack στα 

Assets του project. Τέλος η σκηνή paixnidi_2 περιέχει και το αντικείμενο Image Target (Game 

Object → Vuforia Engine → Image), από το Inspector του οποίου στο πεδίο Image Target 

Behavior (Script) επιλέγουμε στο Database την βάση δεδομένων ptuxiakh_database, που 

δημιουργήσαμε προηγουμένως, και στο Image Target επιλέγουμε το ar_marker4 που 

αντιστοιχεί στο κεφάλαιο ΗΛΕΚΤΡΟΜΑΓΝΗΤΙΣΜΟΣ. Με αυτές τις ρυθμίσεις όταν η 

κάμερα του χρήστη θα διαβάζει το συγκεκριμένο QRcode θα εμφανίζονται στην οθόνη του όλα 

τα αντικείμενα τα οποία δημιουργήθηκαν στη συνέχεια εντός του αντικειμένου Image Target.  

Πιο αναλυτικά, τα αντικείμενα αυτά είναι ένα Plane (Game Object → 3D Object → Plane), το 

οποίο περιέχει την εικόνα που επιλέχθηκε ως δάπεδο για τον συγκεκριμένο λαβύρινθο, είκοσι 

αντικείμενα Cube (Game Object → 3D Object → Cube), με τα οποία σχεδιάστηκαν οι τοίχοι 

του λαβύρινθου και από το Inspector του καθενός έγιναν οι ρυθμίσεις Add Component → Box 

Collider με σκοπό να αποκτήσουν υπόσταση, οκτώ έτοιμα μοντέλα αντικειμένων τα οποία 

φαίνονται στην εικόνα 6.4 και εισάχθηκαν με drag and drop από τον φάκελο models ο οποίος 

είχε δημιουργηθεί προηγουμένως στα Assets του project, ο Robi που είναι ο βασικός 

χαρακτήρας του παιχνιδιού και εισάχθηκε επίσης με drag and drop από τον ίδιο φάκελο, επτά 

αντικείμενα Audio Source (Game Object → Audio → Audio Source) και οκτώ αντικείμενα 

Event System (Game Object → UI → Event System).   

 

Εικόνα 6.4: Υλικά παιχνιδιού για το κεφάλαιο ΗΛΕΚΤΡΟΜΑΓΝΗΤΙΣΜΟΣ 
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Τα επτά αντικείμενα Audio Source, πέντε με τον ήχο extra και δύο με τον ήχο wrong_answer, 

τοποθετήθηκαν πάνω στα επτά από οκτώ υλικά που υπάρχουν εντός του λαβυρίνθου με σκοπό 

να ειδοποιούν τον χρήστη για τη σωστή ή λανθασμένη επιλογή υλικών. Η ενεργοποίηση των 

ήχων αυτών γίνεται με την βοήθεια των οκτώ αντικειμένων Event System, τα οποία έχουν 

επίσης τοποθετηθεί πάνω στα οκτώ υλικά εντός του λαβυρίνθου και φέρουν αντίστοιχη 

ονομασία (EventCandle, Eventmagnet, EventRing, Eventcandlestick, EventNeedle, 

Eventpapper_clip, Eventpencil, EventGlass_end). Επιπλέον, τα οκτώ αντικείμενα Event 

System είναι υπεύθυνα και για την εξαφάνιση των υλικών του πειράματος, τόσο από τον 

λαβύρινθο όσο και από την μπάρα, όταν ο χρήστης τα περισυλλέξει με την βοήθεια του Robi. 

Με βάση τα παραπάνω υπάρχουν τριών ειδών ρυθμίσεις για τα αντικείμενα Event System.  

Οι ρυθμίσεις για τα Event System που αντιστοιχούν στα αντικείμενα που δεν πρέπει να 

συλλέξει ο χρήστης (Κερί, Κηροπήγιο) είναι Inspector → Add Component → Box Collider → 

ενεργοποίηση του πεδίου Is Trigger και Inspector → Add Component → Sound_event (Script) 

και drag and drop το αντίστοιχο αντικείμενο ήχου. Το script που αφορά τις συγκεκριμένες 

ρυθμίσεις είναι ίδιο με αυτό που χρησιμοποιήθηκε για το κεφάλαιο ΘΕΡΜΟΤΗΤΑ και 

φαίνεται στην εικόνα 5.5 του αντίστοιχού κεφαλαίου. 

Οι ρυθμίσεις για τα Event System που πρέπει να συλλέξει ο χρήστης για την υλοποίηση του 

πειράματος (Συνδετήρας, Στυλό, Μαγνήτης, Βελόνα, Δαχτυλίδι) είναι Inspector → Add 

Component → Box Collider → ενεργοποίηση του πεδίου Is Trigger και Inspector → Add 

Component → Trigger_item και στην συνέχεια drag and drop το εκάστοτε μοντέλο 

αντικειμένου, Text – TextMeshPro και το αντίστοιχο αντικείμενο ήχου.  Το script που αφορά 

τις συγκεκριμένες ρυθμίσεις είναι ίδιο με αυτό που χρησιμοποιήθηκε για το κεφάλαιο 

ΘΕΡΜΟΤΗΤΑ και φαίνεται στην εικόνα 5.6 του αντίστοιχού κεφαλαίου. 

Οι τελευταίες ρυθμίσεις για τα Event System αφορούν το τελευταίο υλικό εντός του 

λαβυρίνθου (Ποτήρι), το οποίο εκτός του ρόλου του ως υλικό έχει και την ιδιότητα αλλαγής 

σκηνής. Οι ρυθμίσεις που πρέπει να γίνουν είναι Inspector → Add Component → Box Collider 

→ ενεργοποίηση του πεδίου Is Trigger και Inspector → Add Component → Trigger_item_end 

και στην συνέχεια drag and drop το εκάστοτε μοντέλο αντικειμένου, Text – TextMeshPro και 

το αντίστοιχο αντικείμενο ήχου. Το script που αφορά τις συγκεκριμένες ρυθμίσεις είναι ίδιο με 

αυτό που χρησιμοποιήθηκε για το κεφάλαιο ΘΕΡΜΟΤΗΤΑ και φαίνεται στην εικόνα 5.7 του 

αντίστοιχού κεφαλαίου. 

Η τελική εμφάνιση της σκηνής paixnidi_2 μετά τη δημιουργία και τις ρυθμίσεις όλων των 

αντικειμένων που αναλύσαμε παραπάνω παρουσιάζεται στην εικόνα 6.5. 
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Εικόνα 6.5: Τελική εμφάνιση σκηνής paixnidi_2 

 

6.3.3 Η σκηνή perigrafh_peiramatos_2 

Η σκηνή perigrafh_peiramatos_2 (Εικόνα 6.6) είναι η σκηνή στην οποία μεταβαίνει ο χρήστης 

μόλις ολοκληρώσει το παιχνίδι του λαβυρίνθου που δημιουργήθηκε για το κεφάλαιο 

ΗΛΕΚΤΡΟΜΑΓΝΗΤΙΣΜΟΣ. Η συγκεκριμένη σκηνή αποτελείται από μία Main Camera 

(Game Object → Camera), ένα Directional Light (Game Object → Light → Directional Light), 

ένα Event System (Game Object → UI → Event System) και ενός Canvas (Game Object → UI 

→ Canvas). Τέλος, πάνω στο Canvas δημιουργήθηκε ένα αντικείμενο Panel (Game Object → 

UI → Panel), στο οποίο εισάχθηκε το φόντο της σκηνής από Panel → Image → Source Image, 

και ένα αντικείμενο Empty (Game Object → Create Empty) το οποίο μετονομάστηκε σε 

PERILIPSIMENU και περιέχει συνολικά πέντε αντικείμενα Text-TextMeshPro (Game Object 

→ UI → Text-TextMeshPro) και δύο αντικείμενα Button-TextMeshPro (Game Object → UI 

→ Button-TextMeshPro). Το script [PERILIPSIMENU → Inspector → Add Component → 

Perilipsi (Script)] που χρησιμοποιήθηκε για την λειτουργία των δύο αυτών κουμπιών, είναι 

παρόμοιο με αυτό της Αρχικής σκηνής, το οποίο παρουσιάστηκε αναλυτικά στην υποενότητα 

4.6 και περιέχει τις μεθόδους PLAY() και BACK(). 
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Εικόνα 6.6: Η σκηνή perigrafh_peiramatos_2 

 

6.3.4 Η σκηνή peirama_2 

Η σκηνή peirama_2 είναι η σκηνή στην οποία υλοποιείται το πείραμα του κεφαλαίου 

ΗΛΕΚΤΡΟΜΑΓΝΗΤΙΣΜΟΣ με χρήση επαυξημένης πραγματικότητας. Όπως φαίνεται και 

στην εικόνα 6.7 η συγκεκριμένη σκηνή αποτελείται από ένα Direction Light (Game Object → 

Light → Directional Light), από μία ARCamera (Game Object → Vuforia Engine → AR 

Camera), από ένα AR Session (Game Object → XR → AR Session), ένα Event System (Game 

Object → UI → Event System) και από ένα Image Target (Game Object → Vuforia Engine → 

Image). Στην συνέχεια, από το Inspector του Image Target επιλέχθηκε στο Database στο πεδίο 

Image Target Behavior (Script) η βάση δεδομένων ptuxiakh_database και στο Image Target 

επιλέχθηκε το ar_marker4 που αντιστοιχεί στο κεφάλαιο ΗΛΕΚΤΡΟΜΑΓΝΗΤΙΣΜΟΣ. 

Επιπλέον, στο αντικείμενο Image Target προστέθηκαν με drag and drop από τον φάκελο 

models που βρίσκεται στα Assets του project, το έτοιμο μοντέλο αντικειμένου 

Table_Large_Rectangular_01, δυο φορές ανάλογα με τη θέση τους στο χώρο τα μοντέλα 

αντικειμένων needle, magnet, Paper_clip, Glass, ring, Pencil. Η εμφάνιση ή η απόκρυψη των 
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συγκεκριμένων αντικειμένων γίνεται με βάση το κουμπί που θα επιλέξει ο χρήστης κατά την 

υλοποίηση του πειράματος. Πιο συγκεκριμένα υπάρχουν έξι κουμπιά στην συγκεκριμένη 

σκηνή τα οποία δημιουργήθηκαν από Game Object → UI → Button- TextMeshPro εντός του 

αντικειμένου Canvas που δημιουργήθηκε πάνω στην ARCamera από Game Object → UI → 

Canvas.  

 

 

Εικόνα 6.7: Ιεραρχία αντικειμένων σκηνής peirama_2 

 

Το script το οποίο επιτρέπει τη εναλλαγή μεταξύ των φάσεων του πειράματος σύμφωνα πάντα 

με τις κινήσεις του χρήστη βρίσκεται στο ΠΑΡΑΡΤΗΜΑ Β και για την εισαγωγή του έγιναν 

οι κινήσεις ARCamera → Inspector → Add Component → Peirama 2 (Script) και στην 

συνέχεια με drag and drop έγινε η αντιστοιχία των αντικειμένων της σκηνής ως ορίσματα στο 

script. Οι φάσεις υλοποίησης του πειράματος φαίνονται στην εικόνα 6.8. 
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Εικόνα 6.8: Υλοποίηση πειράματος - ΗΛΕΚΤΡΟΜΑΓΝΗΤΙΣΜΟΣ 

6.3.5 Η σκηνή sumperasma_2 

Η σκηνή sumperasma_2 (Εικόνα 6.9) είναι η τελική σκηνή που δημιουργήθηκε για το κεφάλαιο 

ΗΛΕΚΤΡΟΜΑΓΝΗΤΙΣΜΟΣ και περιέχει την παρατήρηση και το συμπέρασμα του 

πειράματος που υλοποιήθηκε στην προηγούμενη σκηνή. Η συγκεκριμένη σκηνή αποτελείται 

από μία Main Camera (Game Object → Camera), ένα Directional Light (Game Object → Light 

→ Directional Light), ένα Event System (Game Object → UI → Event System) και ενός 

Canvas (Game Object → UI → Canvas). Τέλος, πάνω στο Canvas δημιουργήθηκε ένα 

αντικείμενο Panel (Game Object → UI → Panel), στο οποίο εισάχθηκε το φόντο της σκηνής 

από Panel → Image → Source Image, και ένα αντικείμενο Empty (Game Object → Create 

Empty) το οποίο μετονομάστηκε σε PERILIPSIMENU και περιέχει συνολικά έξι αντικείμενα 

Text-TextMeshPro (Game Object → UI → Text-TextMeshPro) και ένα αντικείμενο Button-
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TextMeshPro (Game Object → UI → Button-TextMeshPro). Το script [PERILIPSIMENU → 

Inspector → Add Component → Perilipsi (Script)] που χρησιμοποιήθηκε για την λειτουργία 

του κουμπιού, είναι παρόμοιο με αυτό της Αρχικής σκηνής, το οποίο παρουσιάστηκε 

αναλυτικά στην υποενότητα 4.6 και περιέχει μόνο την μέθοδο BACK().  

 

Εικόνα 6.9: Η σκηνή sumperasma_2 

 

 

6.4 Επίλογος 

Με τις παραπάνω πέντε σκηνές ολοκληρώνεται η υλοποίηση του πειράματος για το κεφάλαιο 

ΗΛΕΚΤΡΟΜΑΓΝΗΤΙΣΜΟΣ. Με την ολοκλήρωση του πειράματος θα πρέπει να έχουν 

επιτευχθεί οι μαθησιακοί στόχοι που τέθηκαν στην αρχή του κεφαλαίου. 
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Κεφάλαιο 7ο: Εφαρμογή πειράματος για το κεφάλαιο Φως 

7.1 Εισαγωγή 

Στον παρόν κεφάλαιο γίνεται η ανάλυση των μαθησιακών στόχων του πειράματος που 

επιλέχθηκε προς εφαρμογή από το κεφάλαιο ΦΩΣ από το βιβλίο Φυσικά Δημοτικού – Ερευνώ 

και Ανακαλύπτω της ΣΤ’ τάξης. Επιπλέον παρουσιάζονται αναλυτικά όλα τα βήματα που 

ακολουθήθηκαν για την δημιουργία των σκηνών του κεφαλαίου και την υλοποίηση του 

πειράματος με χρήση επαυξημένης πραγματικότητας. 

7.2 Πείραμα ενότητα ΦΕ2: ΦΩΣ ΚΑΙ ΧΡΩΜΑΤΑ 

Η ενότητα ΦΕ2: ΦΩΣ ΚΑΙ ΧΡΩΜΑΤΑ είναι η ενότητα του κεφαλαίου ΦΩΣ του βιβλίου 

Φυσικά Δημοτικού – Ερευνώ και Ανακαλύπτω της ΣΤ’ τάξης της οποίας το πείραμα 

επιλέχθηκε προς υλοποίηση μέσω της εφαρμογής επαυξημένης πραγματικότητας και βρίσκεται 

στη σελίδα 143 του Τετραδίου εργασιών. Ο κύριος στόχος του κεφαλαίου είναι να έρθουν οι 

μαθητές σε επαφή με την έννοια του φωτός και με φαινόμενα όπως η διάθλαση καθώς και να 

κατανοήσουν ότι το φως μεταφέρει πληροφορία και πως αυτή μπορεί να γίνει αντιληπτή από 

το ανθρώπινο μάτι ή από άλλα αντικείμενα όπως ο φακός ή οι καθρέφτες. Πιο συγκεκριμένα, 

το πείραμα της σελίδας 143 εστιάζει στα χρώματα και στοχεύει να συμπεράνουν οι μαθητές 

ότι το λευκό φως είναι σύνθετο και μπορεί να αναλυθεί σε περισσότερα χρώματα όταν περνά 

μέσα από διαφανή σώματα. Για την υλοποίηση του πειράματος απαιτούνται τα αντικείμενα 

μαύρο χαρτόνι, ψαλίδι, ταινία, κυλινδρικό γυάλινο ποτήρι, νερό και λευκό χαρτί. Η εκφώνηση 

του πειράματος ζητάει από τους μαθητές να ανοίξουν στη μέση του μαύρου χαρτονιού μία 

σχισμή με πλάτος περίπου ένα εκατοστό και ύψος περίπου είκοσι εκατοστά και να κολλήσουν 

με ταινία το χαρτόνι στο ποτήρι. Στην συνέχεια, τους ζητά να τοποθετήσουν στον ήλιο το 

ποτήρι με το χαρτόνι, αφού πρώτα το γεμίσουν με νερό, και στην σκιά που δημιουργείται από 

το μαύρο χαρτόνι να τοποθετήσουν οριζόντια το λευκό χαρτί. Με βάση τα παραπάνω οι 

μαθητές θα είναι σε θέση να κατανοήσουν πως το λευκό φως αναλύεται στα χρώματα τα οποία 

περιέχει όταν περνάει μέσα από διαφανή σώματα. Η εφαρμογή PhysicX-R υλοποιεί όλα τα 

παραπάνω με χρήση επαυξημένης πραγματικότητας μέσω ενός QRcode που έχει προστεθεί 

στην σελίδα 143 του Τετραδίου εργασιών. 

7.3 Οι σκηνές του πειράματος – ΦΩΣ 

Η εικόνα 7.1 απεικονίζει τις συνολικά πέντε σκηνές από τις οποίες αποτελείται το πείραμα του 

κεφαλαίου ΦΩΣ, αλλά και την σειρά με την οποία εμφανίζονται εντός της εφαρμογής. Αρχικά, 

ο χρήστης, αφού επιλέξει το κουμπί που αντιστοιχεί στο κεφάλαιο ΦΩΣ από την αρχική σκήνη, 

μεταβαίνει στη σκηνή epilogh_3 στην οποία εμφανίζονται όλα τα διαθέσιμα πειράματα από τις 

διάφορες ενότητες του κεφαλαίου. Στην συνέχεια, πατώντας το κουμπί Ας παίξουμε επιλέγει το 

πείραμα το οποίο θέλει να υλοποιήσει και περνάει στην σκηνή paixnidi_3 όπου ενεργοποιείται 

αυτόματα η κάμερα της συσκευής και σκανάροντας το QRcode που βρίσκεται στην σελίδα 143 

στο Τετράδιο εργασιών, εμφανίζεται μπροστά του ένας λαβύρινθος με χρήση επαυξημένης 

πραγματικότητας και από πάνω μία μπάρα με τα αντικείμενα που πρέπει να συλλέξει. Αφού 
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ολοκληρωθεί η συλλογή όλων των αντικειμένων και βγει ο χρήστης από τον λαβύρινθο 

μεταβαίνει αυτόματα στην σκηνή perigrafh_peiramatos_3 όπου εμφανίζονται οι οδηγίες για 

την υλοποίηση του πειράματος που θα ακολουθήσει. Στην συνέχεια πατώντας το κουμπί Ας 

μάθουμε μεταβαίνει στη σκηνή peirama_3 οπού ενεργοποιείται ξανά η κάμερα του με αυτόματο 

τρόπο και διαβάζοντας το QRcode  της σελίδας 143 εμφανίζεται μπροστά στον χρήστη ένα 

τραπέζι, με χρήση επαυξημένης πραγματικότητας, πάνω στο οποίο υλοποιείται το πείραμα. Σε 

αυτό το σημείο ο χρήστης πατώντας ένα- ένα τα κουμπιά που αντιστοιχούν στα διάφορα 

αντικείμενα από το πάνω μέρος της οθόνης παρατηρεί ποια έλκονται και ποια όχι και στη 

συνέχεια πατώντας το κουμπί ΣΥΜΠΕΡΑΣΜΑ μεταβαίνει στην τελική σκηνή του πειράματος, 

την σκηνή sumperasma_2, όπου εμφανίζονται συμπληρωμένα η παρατήρηση και το 

συμπέρασμα του πειράματος.  

 

Εικόνα 7.1: Σκηνές πειράματος - ΦΩΣ 
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7.3.1 Η σκηνή epilogh_3 

Η σκηνή epilogh_3 (Εικόνα 7.2) αποτελεί την πρώτη σκηνή στην οποία μεταβαίνει ο χρήστης 

μόλις επιλέξει το κουμπί που αντιστοιχεί στο κεφάλαιο ΦΩΣ από την Αρχική σκηνή. Η 

δημιουργία των αντικειμένων της συγκεκριμένης σκηνής έγινε με παρόμοιο τρόπο όπως αυτή 

των αντικειμένων της Αρχικής σκηνής και των σκηνών epilogh_1, epilogh_2. Πιο 

συγκεκριμένα, η σκηνή αποτελείται από μία Main Camera (Game Object → Camera), ένα 

Directional Light (Game Object → Light → Directional Light), ένα Event System (Game 

Object → UI → Event System) και ενός Canvas (Game Object → UI → Canvas). Τέλος, πάνω 

στο Canvas δημιουργήθηκε ένα αντικείμενο Panel (Game Object → UI → Panel), στο οποίο 

εισάχθηκε το φόντο της σκηνής από Panel → Image → Source Image, και ένα αντικείμενο 

Empty (Game Object → Create Empty) το οποίο μετονομάστηκε σε PERILIPSIMENU και 

περιέχει συνολικά έξι αντικείμενα Text-TextMeshPro (Game Object → UI → Text-

TextMeshPro) και δύο αντικείμενα Button-TextMeshPro (Game Object → UI → Button-

TextMeshPro). Το script [PERILIPSIMENU → Inspector → Add Component → Perilipsi_3 

(Script)] που χρησιμοποιήθηκε για την λειτουργία των δύο αυτών κουμπιών, είναι παρόμοιο 

με αυτό της Αρχικής σκηνής, το οποίο παρουσιάστηκε αναλυτικά στην υποενότητα 4.6 και 

περιέχει τις μεθόδους PLAY() και BACK(). 

 

Εικόνα 7.2: Η σκηνή epilogh_3 
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7.3.2 Η σκηνή paixnidi_3 

Πατώντας το κουμπί Ας παίξουμε από την σκηνή epilogh_3 ο χρήστης μεταβαίνει στη σκηνή 

paixnidi_3, όπου ενεργοποιείται η κάμερα του και διαβάζοντας το αντίστοιχο QRcode 

εμφανίζεται μπροστά του ένας λαβύρινθος επαυξημένης πραγματικότητας. Η ιεραρχία των 

αντικειμένων της σκηνής paixnidi_3 φαίνεται στην εικόνα 7.3. 

 

Εικόνα 7.3: Ιεραρχία αντικειμένων σκηνής paixnidi_3 
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Όπως φαίνεται από την εικόνα η συγκεκριμένη σκηνή αποτελείται από ένα Direction Light 

(Game Object → Light → Directional Light), από μία ARCamera (Game Object → Vuforia 

Engine → AR Camera), από ένα AR Session (Game Object → XR → AR Session), από ένα 

Canvas (Game Object → UI → Canvas), το οποίο περιέχει τέσσερα αντικείμενα Text – 

TextMeshPro (Game Object → UI → Text – TextMeshPro) που απαρτίζουν την μπάρα με τα 

υλικά που πρέπει να συλλέξει ο χρήστης από τον λαβύρινθο για την υλοποίηση του πειράματος 

και  το αντικείμενο Fixed Joystick που εισάχθηκε με drag and drop από τον φάκελο Joystick 

pack στα Assets του project. Τέλος η σκηνή paixnidi_3 περιέχει και το αντικείμενο Image 

Target (Game Object → Vuforia Engine → Image), από το Inspector του οποίου στο πεδίο 

Image Target Behavior (Script) επιλέγουμε στο Database την βάση δεδομένων 

ptuxiakh_database, που δημιουργήσαμε προηγουμένως, και στο Image Target επιλέγουμε το 

ar_marker2 που αντιστοιχεί στο κεφάλαιο ΦΩΣ. Με αυτές τις ρυθμίσεις όταν η κάμερα του 

χρήστη θα διαβάζει το συγκεκριμένο QRcode θα εμφανίζονται στην οθόνη του όλα τα 

αντικείμενα τα οποία δημιουργήθηκαν στη συνέχεια εντός του αντικειμένου Image Target.  

Πιο αναλυτικά, τα αντικείμενα αυτά είναι ένα Plane (Game Object → 3D Object → Plane), το 

οποίο περιέχει την εικόνα που επιλέχθηκε ως δάπεδο για τον συγκεκριμένο λαβύρινθο, έντεκα 

αντικείμενα Cube (Game Object → 3D Object → Cube), με τα οποία σχεδιάστηκαν οι τοίχοι 

του λαβύρινθου και από το Inspector του καθενός έγιναν οι ρυθμίσεις Add Component → Box 

Collider με σκοπό να αποκτήσουν υπόσταση, οκτώ έτοιμα μοντέλα αντικειμένων τα οποία 

φαίνονται στην εικόνα 7.4 και εισάχθηκαν με drag and drop από τον φάκελο models ο οποίος 

είχε δημιουργηθεί προηγουμένως στα Assets του project, ο Robi που είναι ο βασικός 

χαρακτήρας του παιχνιδιού και εισάχθηκε επίσης με drag and drop από τον ίδιο φάκελο, οκτώ 

αντικείμενα Audio Source (Game Object → Audio → Audio Source) και οκτώ αντικείμενα 

Event System (Game Object → UI → Event System).   

 

Εικόνα 7.4: Υλικά παιχνιδιού για το κεφάλαιο ΦΩΣ 
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Τα οκτώ αντικείμενα Audio Source, τέσσερα με τον ήχο extra και τέσσερα με τον ήχο 

wrong_answer, τοποθετήθηκαν πάνω στα οκτώ υλικά που υπάρχουν εντός του λαβυρίνθου με 

σκοπό να ειδοποιούν τον χρήστη για τη σωστή ή λανθασμένη επιλογή υλικών. Η ενεργοποίηση 

των ήχων αυτών γίνεται με την βοήθεια των οκτώ αντικειμένων Event System, τα οποία έχουν 

επίσης τοποθετηθεί πάνω στα οκτώ υλικά εντός του λαβυρίνθου και φέρουν αντίστοιχη 

ονομασία (EventRing, EventCandlestick, EventCandle, EventCork, EventPsalidi, EventGlass, 

EventXartoni, EventWater_end). Επιπλέον, τα οκτώ αντικείμενα Event System είναι υπεύθυνα 

και για την εξαφάνιση των υλικών του πειράματος, τόσο από τον λαβύρινθο όσο και από την 

μπάρα, όταν ο χρήστης τα περισυλλέξει με την βοήθεια του Robi. Με βάση τα παραπάνω 

υπάρχουν τριών ειδών ρυθμίσεις για τα αντικείμενα Event System.  

Οι ρυθμίσεις για τα Event System που αντιστοιχούν στα αντικείμενα που δεν πρέπει να 

συλλέξει ο χρήστης (Κερί, Κηροπήγιο, Δαχτυλίδι, Φελλός) είναι Inspector → Add Component 

→ Box Collider → ενεργοποίηση του πεδίου Is Trigger και Inspector → Add Component → 

Sound_event (Script) και drag and drop το αντίστοιχο αντικείμενο ήχου. Το script που αφορά 

τις συγκεκριμένες ρυθμίσεις είναι ίδιο με αυτό που χρησιμοποιήθηκε για το κεφάλαιο 

ΘΕΡΜΟΤΗΤΑ και φαίνεται στην εικόνα 5.5 του αντίστοιχού κεφαλαίου. 

Οι ρυθμίσεις για τα Event System που πρέπει να συλλέξει ο χρήστης για την υλοποίηση του 

πειράματος (Ποτήρι, Ψαλίδι, Χαρτόνι) είναι Inspector → Add Component → Box Collider → 

ενεργοποίηση του πεδίου Is Trigger και Inspector → Add Component → Trigger_item και στην 

συνέχεια drag and drop το εκάστοτε μοντέλο αντικειμένου, Text – TextMeshPro και το 

αντίστοιχο αντικείμενο ήχου.  Το script που αφορά τις συγκεκριμένες ρυθμίσεις είναι ίδιο με 

αυτό που χρησιμοποιήθηκε για το κεφάλαιο ΘΕΡΜΟΤΗΤΑ και φαίνεται στην εικόνα 5.6 του 

αντίστοιχού κεφαλαίου. 

Οι τελευταίες ρυθμίσεις για τα Event System αφορούν το τελευταίο υλικό εντός του 

λαβυρίνθου (Νερό), το οποίο εκτός του ρόλου του ως υλικό έχει και την ιδιότητα αλλαγής 

σκηνής. Οι ρυθμίσεις που πρέπει να γίνουν είναι Inspector → Add Component → Box Collider 

→ ενεργοποίηση του πεδίου Is Trigger και Inspector → Add Component → Trigger_item_end 

και στην συνέχεια drag and drop το εκάστοτε μοντέλο αντικειμένου, Text – TextMeshPro και 

το αντίστοιχο αντικείμενο ήχου. Το script που αφορά τις συγκεκριμένες ρυθμίσεις είναι ίδιο με 

αυτό που χρησιμοποιήθηκε για το κεφάλαιο ΘΕΡΜΟΤΗΤΑ και φαίνεται στην εικόνα 5.7 του 

αντίστοιχού κεφαλαίου. 

Η τελική εμφάνιση της σκηνής paixnidi_3 μετά τη δημιουργία και τις ρυθμίσεις όλων των 

αντικειμένων που αναλύσαμε παραπάνω παρουσιάζεται στην εικόνα 7.5. 
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Εικόνα 7.5: Τελική εμφάνιση σκηνής paixnidi_3 

 

7.3.3 Η σκηνή perigrafh_peiramatos_3 

Η σκηνή perigrafh_peiramatos_3 (Εικόνα 7.6) είναι η σκηνή στην οποία μεταβαίνει ο χρήστης 

μόλις ολοκληρώσει το παιχνίδι του λαβυρίνθου που δημιουργήθηκε για το κεφάλαιο ΦΩΣ. Η 

συγκεκριμένη σκηνή αποτελείται από μία Main Camera (Game Object → Camera), ένα 

Directional Light (Game Object → Light → Directional Light), ένα Event System (Game 

Object → UI → Event System) και ενός Canvas (Game Object → UI → Canvas). Τέλος, πάνω 

στο Canvas δημιουργήθηκε ένα αντικείμενο Panel (Game Object → UI → Panel), στο οποίο 

εισάχθηκε το φόντο της σκηνής από Panel → Image → Source Image, και ένα αντικείμενο 

Empty (Game Object → Create Empty) το οποίο μετονομάστηκε σε PERILIPSIMENU και 

περιέχει συνολικά πέντε αντικείμενα Text-TextMeshPro (Game Object → UI → Text-

TextMeshPro) και δύο αντικείμενα Button-TextMeshPro (Game Object → UI → Button-

TextMeshPro). Το script [PERILIPSIMENU → Inspector → Add Component → Perilipsi 

(Script)] που χρησιμοποιήθηκε για την λειτουργία των δύο αυτών κουμπιών, είναι παρόμοιο 

με αυτό της Αρχικής σκηνής, το οποίο παρουσιάστηκε αναλυτικά στην υποενότητα 4.6 και 

περιέχει τις μεθόδους PLAY() και BACK(). 
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Εικόνα 7.6: Η σκηνή perigrafh_peiramatos_3 

 

7.3.4 Η σκηνή peirama_3 

Η σκηνή peirama_3 είναι η σκηνή στην οποία υλοποιείται το πείραμα του κεφαλαίου ΦΩΣ με 

χρήση επαυξημένης πραγματικότητας. Όπως φαίνεται και στην εικόνα 7.7 η συγκεκριμένη 

σκηνή αποτελείται από ένα Direction Light (Game Object → Light → Directional Light), από 

μία ARCamera (Game Object → Vuforia Engine → AR Camera), από ένα AR Session (Game 

Object → XR → AR Session), ένα Event System (Game Object → UI → Event System) και 

από ένα Image Target (Game Object → Vuforia Engine → Image). Στην συνέχεια, από το 

Inspector του Image Target επιλέχθηκε στο Database στο πεδίο Image Target Behavior (Script) 

η βάση δεδομένων ptuxiakh_database και στο Image Target επιλέχθηκε το ar_marker2 που 

αντιστοιχεί στο κεφάλαιο ΦΩΣ. Επιπλέον, στο αντικείμενο Image Target προστέθηκαν με drag 

and drop από τον φάκελο models που βρίσκεται στα Assets του project, τα έτοιμα μοντέλα 

αντικειμένων Table_Large_Rectangular_01, Glass, Xartoni, scissors, Bottiglia και το 

αντικείμενο POTIRISKIA. Η εμφάνιση ή η απόκρυψη των συγκεκριμένων αντικειμένων 

γίνεται με βάση το κουμπί που θα επιλέξει ο χρήστης κατά την υλοποίηση του πειράματος. Πιο 
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συγκεκριμένα υπάρχουν δύο κουμπιά στην συγκεκριμένη σκηνή τα οποία δημιουργήθηκαν από 

Game Object → UI → Button- TextMeshPro εντός του αντικειμένου Canvas που 

δημιουργήθηκε πάνω στην ARCamera από Game Object → UI → Canvas.  

 

 

Εικόνα 7.7: Ιεραρχία αντικειμένων σκηνής peirama_3 

 

Το script το οποίο επιτρέπει τη εναλλαγή μεταξύ των φάσεων του πειράματος σύμφωνα πάντα 

με τις κινήσεις του χρήστη φαίνεται στην εικόνα 7.8 και για την εισαγωγή του έγιναν οι 

κινήσεις ARCamera → Inspector → Add Component → Peirama 3 (Script) και στην συνέχεια 

με drag and drop έγινε η αντιστοιχία των αντικειμένων της σκηνής ως ορίσματα στο script. Οι 

φάσεις υλοποίησης του πειράματος φαίνονται στην εικόνα 7.9. 
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Εικόνα 7.8: Script “Peirama 3” 
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Εικόνα 7.9: Υλοποίηση πειράματος - ΦΩΣ 

7.3.5 Η σκηνή sumperasma_3 

Η σκηνή sumperasma_3 (Εικόνα 7.10) είναι η τελική σκηνή που δημιουργήθηκε για το 

κεφάλαιο ΦΩΣ και περιέχει την παρατήρηση και το συμπέρασμα του πειράματος που 

υλοποιήθηκε στην προηγούμενη σκηνή. Η συγκεκριμένη σκηνή αποτελείται από μία Main 

Camera (Game Object → Camera), ένα Directional Light (Game Object → Light → Directional 

Light), ένα Event System (Game Object → UI → Event System) και ενός Canvas (Game Object 

→ UI → Canvas). Τέλος, πάνω στο Canvas δημιουργήθηκε ένα αντικείμενο Panel (Game 

Object → UI → Panel), στο οποίο εισάχθηκε το φόντο της σκηνής από Panel → Image → 

Source Image, και ένα αντικείμενο Empty (Game Object → Create Empty) το οποίο 

μετονομάστηκε σε PERILIPSIMENU και περιέχει συνολικά έξι αντικείμενα Text-

TextMeshPro (Game Object → UI → Text-TextMeshPro) και ένα αντικείμενο Button-

TextMeshPro (Game Object → UI → Button-TextMeshPro). Το script [PERILIPSIMENU → 

Inspector → Add Component → Perilipsi (Script)] που χρησιμοποιήθηκε για την λειτουργία 
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του κουμπιού, είναι παρόμοιο με αυτό της Αρχικής σκηνής, το οποίο παρουσιάστηκε 

αναλυτικά στην υποενότητα 4.6 και περιέχει μόνο την μέθοδο BACK().  

 

Εικόνα 7.10: Η σκηνή sumperasma_3 

 

 

7.4 Επίλογος 

Με τις παραπάνω πέντε σκηνές ολοκληρώνεται η υλοποίηση του πειράματος για το κεφάλαιο 

ΦΩΣ. Με την ολοκλήρωση του πειράματος θα πρέπει να έχουν επιτευχθεί οι μαθησιακοί στόχοι 

που τέθηκαν στην αρχή του κεφαλαίου. 
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Κεφάλαιο 8ο: Εφαρμογή πειράματος για το κεφάλαιο Οξέα – 

Βάσεις - Άλατα 

8.1 Εισαγωγή 

Στο κεφάλαιο αυτό, μετά την ανάλυση των μαθησιακών στόχων του Κεφαλαίου ΟΞΕΑ – 

ΒΑΣΕΙΣ - ΑΛΑΤΑ του βιβλίου Φυσικά Δημοτικού – Ερευνώ και Ανακαλύπτω της ΣΤ’ τάξης 

καθώς και του πειράματος που επιλέχθηκε για υλοποίηση μέσω της εφαρμογής, γίνεται μία 

αναλυτική παρουσίαση της διαδικασίας δημιουργίας  όλων των σκηνών για την εφαρμογή του 

συγκεκριμένου πειράματος με χρήση επαυξημένης πραγματικότητας. 

8.2 Πείραμα ενότητα ΦΕ3: ΤΑ ΟΞΕΑ ΚΑΙ ΟΙ ΒΑΣΕΙΣ ΣΤΗΝ ΚΑΘΗΜΕΡΙΝΗ ΖΩΗ 

Η ενότητα ΦΕ3: ΤΑ ΟΞΕΑ ΚΑΙ ΟΙ ΒΑΣΕΙΣ ΣΤΗΝ ΚΑΘΗΜΕΡΙΝΗ ΖΩΗ είναι η ενότητα 

του κεφαλαίου ΟΞΕΑ – ΒΑΣΕΙΣ - ΑΛΑΤΑ του βιβλίου Φυσικά Δημοτικού – Ερευνώ και 

Ανακαλύπτω της ΣΤ’ τάξης της οποίας το πείραμα επιλέχθηκε προς υλοποίηση μέσω της 

εφαρμογής επαυξημένης πραγματικότητας και βρίσκεται στη σελίδα 166 του Τετραδίου 

εργασιών. Ο κύριος στόχος του κεφαλαίου είναι να γνωρίσουν οι μαθητές κάποιες σημαντικές 

κατηγορίες χημικών ουσιών όπως είναι τα οξέα, οι βάσεις και τα άλατα αλλά και να 

αντιληφθούν τα χημικά φαινόμενα και τις χημικές διαδικασίες που λαμβάνουν χώρα συνεχώς 

γύρω μας. Πιο συγκεκριμένα, το πείραμα της σελίδας 166 εστιάζει στα προϊόντα και στις ουσίες 

που χρησιμοποιούμε στην καθημερινότητα και περιέχουν οξέα και βάσεις και επιδιώκει την 

κατανόηση από τους μαθητές των ιδιοτήτων και της χρησιμότητας αυτών. Για την υλοποίηση 

του πειράματος ζητούνται τα υλικά ποτήρια, νερό, απορρυπαντικό, κουταλάκι, ξύδι και 

κιμωλία. Στη συνέχεια, η εκφώνηση του πειράματος ζητάει από τους μαθητές να γεμίσουν ένα 

ποτήρι μέχρι τη μέση περίπου με νερό, να προσθέσουν λίγο απορρυπαντικό και να το 

ανακατέψουν καλά με το κουταλάκι. Επίσης, ζητάει να γεμίσουν το άλλο ποτήρι μέχρι τη μέση 

με ξύδι και να ρίξουν και στα δύο ποτήρια από ένα κομματάκι κιμωλίας.. Σε αυτό το σημείο οι 

μαθητές θα παρατηρήσουν πως στο ποτήρι με το νερό δεν συμβαίνει καμία αλλαγή ενώ 

αντίθετα στο ποτήρι με το ξύδι η κιμωλία αρχίζει να διαλύεται. Με αυτό τον τρόπο οι μαθητές 

οδηγούνται στο συμπέρασμα ότι τα οξέα διαλύουν τα άλατα. Η εφαρμογή PhysicX-R υλοποιεί 

όλα τα παραπάνω με χρήση επαυξημένης πραγματικότητας μέσω ενός QRcode που έχει 

προστεθεί στην σελίδα 166 του Τετραδίου εργασιών. 

8.3 Οι σκηνές του πειράματος – ΟΞΕΑ – ΒΑΣΕΙΣ - ΑΛΑΤΑ 

Η εικόνα 8.1 απεικονίζει τις συνολικά πέντε σκηνές από τις οποίες αποτελείται το πείραμα του 

κεφαλαίου ΟΞΕΑ – ΒΑΣΕΙΣ - ΑΛΑΤΑ, αλλά και την σειρά με την οποία εμφανίζονται εντός της 

εφαρμογής. Αρχικά, ο χρήστης, αφού επιλέξει το κουμπί που αντιστοιχεί στο κεφάλαιο ΟΞΕΑ 

– ΒΑΣΕΙΣ - ΑΛΑΤΑ από την αρχική σκήνη, μεταβαίνει στη σκηνή epilogh_2 στην οποία 

εμφανίζονται όλα τα διαθέσιμα πειράματα από τις διάφορες ενότητες του κεφαλαίου. Στην 

συνέχεια, πατώντας το κουμπί Ας παίξουμε επιλέγει το πείραμα το οποίο θέλει να υλοποιήσει 

και περνάει στην σκηνή paixnidi_2 όπου ενεργοποιείται αυτόματα η κάμερα της συσκευής και 

σκανάροντας το QRcode που βρίσκεται στην σελίδα 123 στο Τετράδιο εργασιών, εμφανίζεται 
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μπροστά του ένας λαβύρινθος με χρήση επαυξημένης πραγματικότητας και από πάνω μία 

μπάρα με τα αντικείμενα που πρέπει να συλλέξει. Αφού ολοκληρωθεί η συλλογή όλων των 

αντικειμένων και βγει ο χρήστης από τον λαβύρινθο μεταβαίνει αυτόματα στην σκηνή 

perigrafh_peiramatos_2 όπου εμφανίζονται οι οδηγίες για την υλοποίηση του πειράματος που 

θα ακολουθήσει. Στην συνέχεια πατώντας το κουμπί Ας μάθουμε μεταβαίνει στη σκηνή 

peirama_2 οπού ενεργοποιείται ξανά η κάμερα του με αυτόματο τρόπο και διαβάζοντας το 

QRcode  της σελίδας 123 εμφανίζεται μπροστά στον χρήστη ένα τραπέζι, με χρήση 

επαυξημένης πραγματικότητας, πάνω στο οποίο υλοποιείται το πείραμα. Σε αυτό το σημείο ο 

χρήστης πατώντας ένα- ένα τα κουμπιά που αντιστοιχούν στα διάφορα αντικείμενα από το 

πάνω μέρος της οθόνης παρατηρεί ποια έλκονται και ποια όχι και στη συνέχεια πατώντας το 

κουμπί ΣΥΜΠΕΡΑΣΜΑ μεταβαίνει στην τελική σκηνή του πειράματος, την σκηνή 

sumperasma_2, όπου εμφανίζονται συμπληρωμένα η παρατήρηση και το συμπέρασμα του 

πειράματος.  
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Εικόνα 8.1: Σκηνές πειράματος - ΟΞΕΑ – ΒΑΣΕΙΣ - ΑΛΑΤΑ 

 

8.3.1 Η σκηνή epilogh_4 

Η σκηνή epilogh_4 (Εικόνα 8.2) αποτελεί την πρώτη σκηνή στην οποία μεταβαίνει ο χρήστης 

μόλις επιλέξει το κουμπί που αντιστοιχεί στο κεφάλαιο ΟΞΕΑ – ΒΑΣΕΙΣ - ΑΛΑΤΑ από την 

Αρχική σκηνή. Η δημιουργία των αντικειμένων της συγκεκριμένης σκηνής έγινε με παρόμοιο 

τρόπο όπως αυτή των αντικειμένων της Αρχικής σκηνής και των σκηνών epilogh_1, epilogh_2, 

epilogh_3. Έτσι, η σκηνή αποτελείται από μία Main Camera (Game Object → Camera), ένα 

Directional Light (Game Object → Light → Directional Light), ένα Event System (Game 

Object → UI → Event System) και ενός Canvas (Game Object → UI → Canvas). Τέλος, πάνω 

στο Canvas δημιουργήθηκε ένα αντικείμενο Panel (Game Object → UI → Panel), στο οποίο 

εισάχθηκε το φόντο της σκηνής από Panel → Image → Source Image, και ένα αντικείμενο 
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Empty (Game Object → Create Empty) το οποίο μετονομάστηκε σε PERILIPSIMENU και 

περιέχει συνολικά τέσσερα αντικείμενα Text-TextMeshPro (Game Object → UI → Text-

TextMeshPro) και δύο αντικείμενα Button-TextMeshPro (Game Object → UI → Button-

TextMeshPro). Το script [PERILIPSIMENU → Inspector → Add Component → Perilipsi_4 

(Script)] που χρησιμοποιήθηκε για την λειτουργία των δύο αυτών κουμπιών, είναι παρόμοιο 

με αυτό της Αρχικής σκηνής, το οποίο παρουσιάστηκε αναλυτικά στην υποενότητα 4.6 και 

περιέχει τις μεθόδους PLAY() και BACK(). 

 

Εικόνα 8.2: Η σκηνή epilogh_4 

8.3.2 Η σκηνή paixnidi_4 

Πατώντας το κουμπί Ας παίξουμε από την σκηνή epilogh_4 ο χρήστης μεταβαίνει στη σκηνή 

paixnidi_4, όπου ενεργοποιείται η κάμερα του και διαβάζοντας το αντίστοιχο QRcode 

εμφανίζεται μπροστά του ένας λαβύρινθος επαυξημένης πραγματικότητας. Η ιεραρχία των 

αντικειμένων της σκηνής paixnidi_4 φαίνεται στην εικόνα 8.3. 
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Εικόνα 8.3: Ιεραρχία αντικειμένων σκηνής paixnidi_4 
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Όπως φαίνεται από την εικόνα η συγκεκριμένη σκηνή αποτελείται από ένα Direction Light 

(Game Object → Light → Directional Light), από μία ARCamera (Game Object → Vuforia 

Engine → AR Camera), από ένα AR Session (Game Object → XR → AR Session), από ένα 

Canvas (Game Object → UI → Canvas), το οποίο περιέχει έξι αντικείμενα Text – TextMeshPro 

(Game Object → UI → Text – TextMeshPro) που απαρτίζουν την μπάρα με τα υλικά που 

πρέπει να συλλέξει ο χρήστης από τον λαβύρινθο για την υλοποίηση του πειράματος και  το 

αντικείμενο Fixed Joystick που εισάχθηκε με drag and drop από τον φάκελο Joystick pack στα 

Assets του project. Τέλος η σκηνή paixnidi_4 περιέχει και το αντικείμενο Image Target (Game 

Object → Vuforia Engine → Image), από το Inspector του οποίου στο πεδίο Image Target 

Behavior (Script) επιλέγουμε στο Database την βάση δεδομένων ptuxiakh_database, που 

δημιουργήσαμε προηγουμένως, και στο Image Target επιλέγουμε το ar_marker1 που 

αντιστοιχεί στο κεφάλαιο ΟΞΕΑ – ΒΑΣΕΙΣ - ΑΛΑΤΑ. Με αυτές τις ρυθμίσεις όταν η κάμερα 

του χρήστη θα διαβάζει το συγκεκριμένο QRcode θα εμφανίζονται στην οθόνη του όλα τα 

αντικείμενα τα οποία δημιουργήθηκαν στη συνέχεια εντός του αντικειμένου Image Target.  

Πιο αναλυτικά, τα αντικείμενα αυτά είναι ένα Plane (Game Object → 3D Object → Plane), το 

οποίο περιέχει την εικόνα που επιλέχθηκε ως δάπεδο για τον συγκεκριμένο λαβύρινθο, έντεκα 

αντικείμενα Cube (Game Object → 3D Object → Cube), με τα οποία σχεδιάστηκαν οι τοίχοι 

του λαβύρινθου και από το Inspector του καθενός έγιναν οι ρυθμίσεις Add Component → Box 

Collider με σκοπό να αποκτήσουν υπόσταση, δώδεκα έτοιμα μοντέλα αντικειμένων τα οποία 

φαίνονται στην εικόνα 8.4 και εισάχθηκαν με drag and drop από τον φάκελο models ο οποίος 

είχε δημιουργηθεί προηγουμένως στα Assets του project, ο Robi που είναι ο βασικός 

χαρακτήρας του παιχνιδιού και εισάχθηκε επίσης με drag and drop από τον ίδιο φάκελο, 

δώδεκα αντικείμενα Audio Source (Game Object → Audio → Audio Source) και δώδεκα 

αντικείμενα Event System (Game Object → UI → Event System).   

 

Εικόνα 8.4: Υλικά παιχνιδιού για το κεφάλαιο ΟΞΕΑ – ΒΑΣΕΙΣ - ΑΛΑΤΑ 
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Τα δώδεκα αντικείμενα Audio Source, έξι με τον ήχο extra και έξι με τον ήχο wrong_answer, 

τοποθετήθηκαν πάνω στα δώδεκα υλικά που υπάρχουν εντός του λαβυρίνθου με σκοπό να 

ειδοποιούν τον χρήστη για τη σωστή ή λανθασμένη επιλογή υλικών. Η ενεργοποίηση των ήχων 

αυτών γίνεται με την βοήθεια των δώδεκα αντικειμένων Event System, τα οποία έχουν επίσης 

τοποθετηθεί πάνω στα οκτώ υλικά εντός του λαβυρίνθου και φέρουν αντίστοιχη ονομασία 

(EventCandle, EventCork, EventRing, Eventcandlestick, EventScissors, EventMpoukali, 

Eventpencil, EventKimolia, EventKoutali, EventGlass, EventAporipadiko, EventKsidi_end). 

Επιπλέον, τα δώδεκα αντικείμενα Event System είναι υπεύθυνα και για την εξαφάνιση των 

υλικών του πειράματος, τόσο από τον λαβύρινθο όσο και από την μπάρα, όταν ο χρήστης τα 

περισυλλέξει με την βοήθεια του Robi. Με βάση τα παραπάνω υπάρχουν τριών ειδών ρυθμίσεις 

για τα αντικείμενα Event System.  

Οι ρυθμίσεις για τα Event System που αντιστοιχούν στα αντικείμενα που δεν πρέπει να 

συλλέξει ο χρήστης (Δαχτυλίδι, Κηροπήγιο, Ψαλίδι, Στυλό, Φελλό, Κερί) είναι Inspector → 

Add Component → Box Collider → ενεργοποίηση του πεδίου Is Trigger και Inspector → Add 

Component → Sound_event (Script) και drag and drop το αντίστοιχο αντικείμενο ήχου. Το 

script που αφορά τις συγκεκριμένες ρυθμίσεις είναι ίδιο με αυτό που χρησιμοποιήθηκε για το 

κεφάλαιο ΘΕΡΜΟΤΗΤΑ και φαίνεται στην εικόνα 5.5 του αντίστοιχού κεφαλαίου. 

Οι ρυθμίσεις για τα Event System που πρέπει να συλλέξει ο χρήστης για την υλοποίηση του 

πειράματος (Νερό, Κουταλάκι, Κιμωλία, Απορρυπαντικό, Ποτήρια) είναι Inspector → Add 

Component → Box Collider → ενεργοποίηση του πεδίου Is Trigger και Inspector → Add 

Component → Trigger_item και στην συνέχεια drag and drop το εκάστοτε μοντέλο 

αντικειμένου, Text – TextMeshPro και το αντίστοιχο αντικείμενο ήχου.  Το script που αφορά 

τις συγκεκριμένες ρυθμίσεις είναι ίδιο με αυτό που χρησιμοποιήθηκε για το κεφάλαιο 

ΘΕΡΜΟΤΗΤΑ και φαίνεται στην εικόνα 5.6 του αντίστοιχού κεφαλαίου. 

Οι τελευταίες ρυθμίσεις για τα Event System αφορούν το τελευταίο υλικό εντός του 

λαβυρίνθου (Ξύδι), το οποίο εκτός του ρόλου του ως υλικό έχει και την ιδιότητα αλλαγής 

σκηνής. Οι ρυθμίσεις που πρέπει να γίνουν είναι Inspector → Add Component → Box Collider 

→ ενεργοποίηση του πεδίου Is Trigger και Inspector → Add Component → Trigger_item_end 

και στην συνέχεια drag and drop το εκάστοτε μοντέλο αντικειμένου, Text – TextMeshPro και 

το αντίστοιχο αντικείμενο ήχου. Το script που αφορά τις συγκεκριμένες ρυθμίσεις είναι ίδιο με 

αυτό που χρησιμοποιήθηκε για το κεφάλαιο ΘΕΡΜΟΤΗΤΑ και φαίνεται στην εικόνα 5.7 του 

αντίστοιχού κεφαλαίου. 

Η τελική εμφάνιση της σκηνής paixnidi_4 μετά τη δημιουργία και τις ρυθμίσεις όλων των 

αντικειμένων που αναλύσαμε παραπάνω παρουσιάζεται στην εικόνα 8.5. 
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Εικόνα 8.5: Τελική εμφάνιση σκηνής paixnidi_4 

 

8.3.3 Η σκηνή perigrafh_peiramatos_4 

Η σκηνή perigrafh_peiramatos_4 (Εικόνα 8.6) είναι η σκηνή στην οποία μεταβαίνει ο χρήστης 

μόλις ολοκληρώσει το παιχνίδι του λαβυρίνθου που δημιουργήθηκε για το κεφάλαιο ΟΞΕΑ – 

ΒΑΣΕΙΣ - ΑΛΑΤΑ. Η συγκεκριμένη σκηνή αποτελείται από μία Main Camera (Game Object 

→ Camera), ένα Directional Light (Game Object → Light → Directional Light), ένα Event 

System (Game Object → UI → Event System) και ενός Canvas (Game Object → UI → 

Canvas). Τέλος, πάνω στο Canvas δημιουργήθηκε ένα αντικείμενο Panel (Game Object → UI 

→ Panel), στο οποίο εισάχθηκε το φόντο της σκηνής από Panel → Image → Source Image, και 

ένα αντικείμενο Empty (Game Object → Create Empty) το οποίο μετονομάστηκε σε 

PERILIPSIMENU και περιέχει συνολικά πέντε αντικείμενα Text-TextMeshPro (Game Object 

→ UI → Text-TextMeshPro) και δύο αντικείμενα Button-TextMeshPro (Game Object → UI 

→ Button-TextMeshPro). Το script [PERILIPSIMENU → Inspector → Add Component → 

Perilipsi (Script)] που χρησιμοποιήθηκε για την λειτουργία των δύο αυτών κουμπιών, είναι 

παρόμοιο με αυτό της Αρχικής σκηνής, το οποίο παρουσιάστηκε αναλυτικά στην υποενότητα 

4.6 και περιέχει τις μεθόδους PLAY() και BACK(). 
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Εικόνα 8.6: Η σκηνή perigrafh_peiramatos_4 

 

8.3.4 Η σκηνή peirama_4 

Η σκηνή peirama_4 είναι η σκηνή στην οποία υλοποιείται το πείραμα του κεφαλαίου ΟΞΕΑ – 

ΒΑΣΕΙΣ - ΑΛΑΤΑ με χρήση επαυξημένης πραγματικότητας. Όπως φαίνεται και στην εικόνα 

8.7 η συγκεκριμένη σκηνή αποτελείται από ένα Direction Light (Game Object → Light → 

Directional Light), από μία ARCamera (Game Object → Vuforia Engine → AR Camera), από 

ένα AR Session (Game Object → XR → AR Session), ένα Event System (Game Object → UI 

→ Event System) και από ένα Image Target (Game Object → Vuforia Engine → Image). Στην 

συνέχεια, από το Inspector του Image Target επιλέχθηκε στο Database στο πεδίο Image Target 

Behavior (Script) η βάση δεδομένων ptuxiakh_database και στο Image Target επιλέχθηκε το 

ar_marker1 που αντιστοιχεί στο κεφάλαιο ΟΞΕΑ – ΒΑΣΕΙΣ - ΑΛΑΤΑ. Επιπλέον, στο 

αντικείμενο Image Target προστέθηκαν με drag and drop από τον φάκελο models που 

βρίσκεται στα Assets του project, τα έτοιμα μοντέλα αντικειμένων 

Table_Large_Rectangular_01, spoon, Glass, Bottiglia, aporipadiko, ksidi, KSIDOPOTIRO, 



Κεφάλαιο 8 

88 

NEROPOTIRO, KSIDOPOTIROAPORI, NEROPOTIRIAPORI, και τέσσερις φορές ανάλογα 

με τη θέση του στο χώρο το μοντέλο αντικειμένου kimolia. Η εμφάνιση ή η απόκρυψη των 

συγκεκριμένων αντικειμένων γίνεται με βάση το κουμπί που θα επιλέξει ο χρήστης κατά την 

υλοποίηση του πειράματος. Πιο συγκεκριμένα υπάρχουν πέντε κουμπιά στην συγκεκριμένη 

σκηνή τα οποία δημιουργήθηκαν από Game Object → UI → Button- TextMeshPro εντός του 

αντικειμένου Canvas που δημιουργήθηκε πάνω στην ARCamera από Game Object → UI → 

Canvas.  

 

 

Εικόνα 8.7: Ιεραρχία αντικειμένων σκηνής peirama_4 

 

Το script το οποίο επιτρέπει τη εναλλαγή μεταξύ των φάσεων του πειράματος σύμφωνα πάντα 

με τις κινήσεις του χρήστη βρίσκεται στο ΠΑΡΑΡΤΗΜΑ C και για την εισαγωγή του έγιναν 

οι κινήσεις ARCamera → Inspector → Add Component → Peirama 4 (Script) και στην 

συνέχεια με drag and drop έγινε η αντιστοιχία των αντικειμένων της σκηνής ως ορίσματα στο 

script. Οι φάσεις υλοποίησης του πειράματος φαίνονται στην εικόνα 8.8. 
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Εικόνα 8.8: Υλοποίηση πειράματος - ΟΞΕΑ – ΒΑΣΕΙΣ - ΑΛΑΤΑ 

8.3.5 Η σκηνή sumperasma_4 

Η σκηνή sumperasma_4 (Εικόνα 8.9) είναι η τελική σκηνή που δημιουργήθηκε για το κεφάλαιο 

ΟΞΕΑ – ΒΑΣΕΙΣ - ΑΛΑΤΑ και περιέχει την παρατήρηση και το συμπέρασμα του πειράματος 

που υλοποιήθηκε στην προηγούμενη σκηνή. Η συγκεκριμένη σκηνή αποτελείται από μία Main 

Camera (Game Object → Camera), ένα Directional Light (Game Object → Light → Directional 

Light), ένα Event System (Game Object → UI → Event System) και ενός Canvas (Game Object 

→ UI → Canvas). Τέλος, πάνω στο Canvas δημιουργήθηκε ένα αντικείμενο Panel (Game 

Object → UI → Panel), στο οποίο εισάχθηκε το φόντο της σκηνής από Panel → Image → 

Source Image, και ένα αντικείμενο Empty (Game Object → Create Empty) το οποίο 

μετονομάστηκε σε PERILIPSIMENU και περιέχει συνολικά έξι αντικείμενα Text-

TextMeshPro (Game Object → UI → Text-TextMeshPro) και ένα αντικείμενο Button-

TextMeshPro (Game Object → UI → Button-TextMeshPro). Το script [PERILIPSIMENU → 
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Inspector → Add Component → Perilipsi (Script)] που χρησιμοποιήθηκε για την λειτουργία 

του κουμπιού, είναι παρόμοιο με αυτό της Αρχικής σκηνής, το οποίο παρουσιάστηκε 

αναλυτικά στην υποενότητα 4.6 και περιέχει μόνο την μέθοδο BACK().  

 

Εικόνα 8.9: Η σκηνή sumperasma_4 

 

 

8.4 Επίλογος 

Με τις παραπάνω πέντε σκηνές ολοκληρώνεται η υλοποίηση του πειράματος για το κεφάλαιο 

ΟΞΕΑ- ΒΑΣΕΙΣ- ΑΛΑΤΑ. Με την ολοκλήρωση του πειράματος θα πρέπει να έχουν επιτευχθεί 

οι μαθησιακοί στόχοι που τέθηκαν στην αρχή του κεφαλαίου. 
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Κεφάλαιο 9ο: Συμπεράσματα και προτάσεις 

Μετά την ολοκλήρωση του σχεδιασμού της εφαρμογής PhysicX-R και της εκπόνησης της 

παρούσας διπλωματικής εργασίας προέκυψαν τα παρακάτω συμπεράσματα: 

1. Οι τεχνολογίες εκτεταμένης πραγματικότητας αποτελούν ένα σύγχρονο μέσο που 

επιτρέπει τον σχεδιασμό και τη διαμόρφωση ποικίλων και προσαρμοσμένων 

εκπαιδευτικών πλαισίων και δραστηριοτήτων ανάλογα με το εκάστοτε διδακτικό 

περιεχόμενο. Μάλιστα, οι τεχνολογίες αυτές παρέχουν στους εκπαιδευόμενους τη 

δυνατότητα εμπειρικής ενασχόλησης με αντικείμενα και περιβάλλοντα με τα οποία θα 

ήταν αδύνατον να έρθουν σε επαφή στο φυσικό κόσμο για διάφορους λόγους. 

2. Η ενσωμάτωση των τεχνολογιών εκτεταμένης πραγματικότητας στην εκπαίδευση 

δύναται να συνεισφέρει δυναμικά στη μάθηση. Οι πλούσιες διαδραστικές 

προσομοιώσεις και οπτικοποιήσεις σε συνδυασμό με τα παιγνιώδη χαρακτηριστικά των 

τεχνολογιών αυτών κάνουν πιο ευχάριστη την εκπαιδευτική διαδικασία, αυξάνουν την 

συμμετοχή και το ενδιαφέρον των μαθητευόμενων με αποτέλεσμα να παρέχουν 

καλύτερα μαθησιακά αποτελέσματα από τα συμβατικά δασκαλοκεντρικά μοντέλα 

διδασκαλίας.  

3. Οι εκπαιδευτικές εφαρμογές που κάνουν χρήση των τεχνολογιών εκτεταμένης 

πραγματικότητας αποτελούν ιδανικά εργαλεία μάθησης για όλους τους μαθητές 

ανεξαρτήτου επιπέδου και ικανοτήτων και δίνουν την ευκαιρία σε όλους τους μαθητές 

να συμμετέχουν ενεργά στο μάθημα και με τους ρυθμούς, προσφέροντας με αυτό τον 

τρόπο μία δίκαιη και χωρίς προκαταλήψεις εκπαίδευση.  

4. Οι εφαρμογές εκτεταμένης πραγματικότητας πλαισιώνουν τη μάθηση με ποικίλους 

τρόπους και σε ποικίλα περιβάλλοντα. Επίσης, παρέχουν μεγάλη ευελιξία και η  

ενσωμάτωση τους στη διδακτική διαδικασία μπορεί να γίνει είτε στο πλαίσιο της 

σχολικής αίθουσας είτε σε οποιεσδήποτε άλλες συνθήκες, χαρακτηριστικό που τις 

καθιστά ένα πολύ χρήσιμο εργαλείο στην εξ αποστάσεως εκπαίδευση που κερδίζει όλο 

και περισσότερο έδαφος τα τελευταία χρόνια.  

5. Το Unity αποτελεί μία πανίσχυρη πλατφόρμα που παρέχει τη δυνατότητα εύκολου και 

γρήγορου σχεδιασμού εφαρμογών εκτεταμένης πραγματικότητας. Οι απεριόριστες 

δυνατότητες που προσφέρει επιτρέπουν την δημιουργία εφαρμογών πάντως τύπου που 

με την ενσωμάτωση εκπαιδευτικών στοιχείων μπορούν να οδηγήσουν αποτελεσματικά 

στη μάθηση. 

Συνοπτικά οι προτάσεις για μελλοντική βελτίωση είναι: 

1. Δημιουργία περισσότερων παιχνιδιών και πειραμάτων ανά κεφάλαιο. 

2. Επέκταση της χρήσης της σε άλλα μαθήματα και τάξεις του δημοτικού και του 

γυμνασίου. 

3. Αντικατάσταση των QRcodes με ανάγνωση σελίδας βιβλίου. 

4. Βελτίωση των γραφικών και του κώδικα της εφαρμογής. 

5. Προσθήκη περισσότερων ηχητικών και εικονικών effects. 

6. Προσθήκη της εφαρμογής στο playstore. 

7. Πειραματική χρήση της εφαρμογής στη ΣΤ’ Δημοτικού. 
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ΠΑΡΑΡΤΗΜΑ A : Script “thesh.cs” 

1. using System.Collections; 
2. using System.Collections.Generic; 
3. using UnityEngine; 
4. using UnityEngine.UI; 
5. using UnityEngine.EventSystems; 
6. using UnityEngine.SceneManagement; 
7.  
8. public class thesh : MonoBehaviour 
9. { 
10. public GameObject model; 
11. public GameObject model2; 
12. public GameObject model3; 
13. public GameObject model4; 
14. public GameObject model5; 
15. public GameObject model6; 
16. public GameObject model7; 
17. public GameObject model8; 
18. public GameObject model9; 
19. public GameObject model10; 
20.  
21. public void Phase1() 
22. { 
23.  
24. model.SetActive(false); 
25. model2.SetActive(false); 
26. model3.SetActive(true); 
27. model4.SetActive(true); 
28. model5.SetActive(true); 
29. model6.SetActive(true); 
30. model7.SetActive(true); 
31. model8.SetActive(false); 
32. model9.SetActive(false); 
33. model10.SetActive(false); 
34. } 
35.  
36. public void Phase2() 
37. { 
38.  
39. model.SetActive(false); 
40. model2.SetActive(false); 
41. model3.SetActive(true); 
42. model4.SetActive(true); 
43. model5.SetActive(false); 
44. model6.SetActive(true); 
45. model7.SetActive(true); 
46. model8.SetActive(true); 
47. model9.SetActive(false); 
48. model10.SetActive(false); 
49. } 
50.  
51. public void Phase3() 
52. { 
53. model.SetActive(false); 
54. model2.SetActive(false); 
55. model3.SetActive(true); 
56. model4.SetActive(true); 
57. model5.SetActive(false); 
58. model6.SetActive(false); 
59. model7.SetActive(true); 
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60. model8.SetActive(true); 
61. model9.SetActive(true); 
62. model10.SetActive(false); 
63. } 
64.  
65. public void Phase4() 
66. { 
67. model.SetActive(false); 
68. model2.SetActive(false); 
69. model3.SetActive(true); 
70. model4.SetActive(true); 
71. model5.SetActive(false); 
72. model6.SetActive(false); 
73. model7.SetActive(false); 
74. model8.SetActive(true); 
75. model9.SetActive(true); 
76. model10.SetActive(true); 
77. } 
78.  
79. public void EPOMENO() 
80. { 
81. SceneManager.LoadScene(SceneManager.GetActiveScene().buildIndex + 4); 
82. } 
83.  
84. } 
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ΠΑΡΑΡΤΗΜΑ Β: Script “peirama2.cs” 

1. using System.Collections; 
2. using System.Collections.Generic; 
3. using UnityEngine; 
4. using UnityEngine.SceneManagement; 
5.  
6. public class peirama2 : MonoBehaviour 
7. { 
8.  
9. public GameObject model; 
10. public GameObject model2; 
11. public GameObject model3; 
12. public GameObject model4; 
13. public GameObject model5; 
14. public GameObject model6; 
15. public GameObject model7; 
16. public GameObject model8; 
17. public GameObject model9; 
18. public GameObject model10; 
19. public GameObject model11; 
20. public GameObject model12; 
21.  
22. public void Sindetiras() 
23. { 
24. model.SetActive(true); 
25. model2.SetActive(true); 
26. model3.SetActive(false); 
27. model4.SetActive(false); 
28. model5.SetActive(false); 
29. model6.SetActive(false); 
30. model7.SetActive(false); 
31. model8.SetActive(false); 
32. model9.SetActive(false); 
33. model10.SetActive(false); 
34. model11.SetActive(false); 
35. model12.SetActive(false); 
36.  
37. } 
38.  
39. public void Potiri() 
40. { 
41. model.SetActive(true); 
42. model2.SetActive(false); 
43. model3.SetActive(true); 
44. model4.SetActive(false); 
45. model5.SetActive(false); 
46. model6.SetActive(false); 
47. model7.SetActive(false); 
48. model8.SetActive(false); 
49. model9.SetActive(false); 
50. model10.SetActive(false); 
51. model11.SetActive(false); 
52. model12.SetActive(false); 
53. } 
54.  
55. public void Velona() 
56. { 
57. model.SetActive(true); 
58. model2.SetActive(false); 
59. model3.SetActive(false); 
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60. model4.SetActive(true); 
61. model5.SetActive(false); 
62. model6.SetActive(false); 
63. model7.SetActive(false); 
64. model8.SetActive(false); 
65. model9.SetActive(false); 
66. model10.SetActive(false); 
67. model11.SetActive(false); 
68. model12.SetActive(false); 
69. } 
70.  
71. public void Daxtilidi() 
72. { 
73. model.SetActive(true); 
74. model2.SetActive(false); 
75. model3.SetActive(false); 
76. model4.SetActive(false); 
77. model5.SetActive(true); 
78. model6.SetActive(false); 
79. model7.SetActive(false); 
80. model8.SetActive(false); 
81. model9.SetActive(false); 
82. model10.SetActive(false); 
83. model11.SetActive(false); 
84. model12.SetActive(false); 
85. } 
86.  
87. public void Stilo() 
88. { 
89. model.SetActive(true); 
90. model2.SetActive(false); 
91. model3.SetActive(false); 
92. model4.SetActive(false); 
93. model5.SetActive(false); 
94. model6.SetActive(true); 
95. model7.SetActive(false); 
96. model8.SetActive(false); 
97. model9.SetActive(false); 
98. model10.SetActive(false); 
99. model11.SetActive(false); 
100. model12.SetActive(false); 
101. } 
102.  
103. public void EPOMENO() 
104. { 
105. SceneManager.LoadScene(SceneManager.GetActiveScene().buildIndex + 4); 
106. } 
107.  
108. } 
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ΠΑΡΑΡΤΗΜΑ C: Script “peirama4.cs” 

1. using System.Collections; 
2. using System.Collections.Generic; 
3. using UnityEngine; 
4. using UnityEngine.SceneManagement; 
5.  
6. public class peirama4 : MonoBehaviour 
7. { 
8. public GameObject model; 
9. public GameObject model2; 
10. public GameObject model3; 
11. public GameObject model4; 
12. public GameObject model5; 
13. public GameObject model6; 
14. public GameObject model7; 
15. public GameObject model8; 
16. public GameObject model9; 
17. public GameObject model10; 
18. public GameObject model11; 
19. public GameObject model12; 
20. public GameObject model13; 
21.  
22. public void Phase1() 
23. { 
24. model.SetActive(false); 
25. model2.SetActive(false); 
26. model3.SetActive(false); 
27. model4.SetActive(false); 
28. model5.SetActive(false); 
29. model6.SetActive(false); 
30. model7.SetActive(true); 
31. model8.SetActive(true); 
32. model9.SetActive(false); 
33. model10.SetActive(false); 
34. model11.SetActive(false); 
35. model12.SetActive(false); 
36. model13.SetActive(false); 
37. } 
38.  
39. public void Phase2() 
40. { 
41. model.SetActive(false); 
42. model2.SetActive(false); 
43. model3.SetActive(false); 
44. model4.SetActive(false); 
45. model5.SetActive(false); 
46. model6.SetActive(false); 
47. model7.SetActive(false); 
48. model8.SetActive(false); 
49. model9.SetActive(true); 
50. model10.SetActive(true); 
51. model11.SetActive(false); 
52. model12.SetActive(false); 
53. model13.SetActive(false); 
54. } 
55. public void Phase3() 
56. { 
57. model.SetActive(false); 
58. model2.SetActive(false); 
59. model3.SetActive(false); 
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60. model4.SetActive(false); 
61. model5.SetActive(false); 
62. model6.SetActive(false); 
63. model7.SetActive(false); 
64. model8.SetActive(false); 
65. model9.SetActive(true); 
66. model10.SetActive(true); 
67. model11.SetActive(true); 
68. model12.SetActive(true); 
69. model13.SetActive(false); 
70. } 
71.  
72. public void Phase4() 
73. { 
74. model.SetActive(false); 
75. model2.SetActive(false); 
76. model3.SetActive(false); 
77. model4.SetActive(false); 
78. model5.SetActive(false); 
79. model6.SetActive(false); 
80. model7.SetActive(false); 
81. model8.SetActive(false); 
82. model9.SetActive(true); 
83. model10.SetActive(true); 
84. model11.SetActive(false); 
85. model12.SetActive(true); 
86. model13.SetActive(true); 
87. } 
88.  
89. public void EPOMENO() 
90. { 
91. SceneManager.LoadScene(SceneManager.GetActiveScene().buildIndex + 4); 
92. } 
93.  
94. } 

 
 


